[prod] Unable to delete marks in /moderate/

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: mbrandt, Assigned: adam)

Tracking

Details

(Whiteboard: [prod])

(Reporter)

Description

7 years ago
Unable to delete marks in the /moderate/ page. Unfortunately I'm not getting a traceback email so this is the only data I have. 

Steps to reproduce:
1. go to /moderate/
2. chose and delete a mark

[11:17:49.748] [Wed Jun 08 2011 11:17:49 GMT-0700 (PDT)] runRoute get #/moderate/YQNK
[11:17:53.672] POST https://markup.mozilla.org/requests/delete_mark [HTTP/1.1 500 INTERNAL SERVER ERROR 95ms]

POSTDATA=reference=YQNK
Assignee: nobody → jbresnik
Blocks: 628811

Comment 1

7 years ago
Not able to recreate this - can  I get a copy of the database?  or even that complete record for YQNK - thanks

Comment 2

7 years ago
Got the database (thanks) - testing now
mbrandt: To see which expected error condition is behind this, listen to the request with tamperdata and right click -> view source. It'll show you the JSON error string that the app sent to you but did not show you.

Comment 4

7 years ago
So far I haven't been able to recreate this even with the production data set..  I'm assuming it's data related so looking into what missing / erroneous data might cause this..
Priority: -- → P1
(Reporter)

Comment 5

7 years ago
Just an update... as of this morning moderation is working for me. lvmesa and I are working to reproduce the error. We'll give an update soon.
This seems to be working--moving to no milestone to keep it in mind.
Target Milestone: 1.1 → ---

Comment 7

7 years ago
Confirmed what is going on here - essentially the mark has been deleted already but is still in the cache (or potentially in someone's rendered view) which means that when its triggered to be deleted again it's not there and the app throws a 500 - so clearly that's wrong and I have changed it use a 404 - frontend still needs to be updated to handle a 404 though, i.e. it's not quite done but assigning to Adam so he can take a look in the next milestone iteration

Updated

7 years ago
Assignee: jbresnik → adam
(Assignee)

Comment 8

7 years ago
The front end was already setup to handle 404s. I did alter the error messages though so they wouldn't send you back to #/linear/ after dismissing one. It will now send you back to #/moderate/ instead so you stay in the admin context. 

https://github.com/mozilla/markup/commit/acf1dae5e89baa0e9761291126f0f138b4b21ab7
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.