Bug 66299 (CacheExplorer)

Implement a browser cache window

RESOLVED WONTFIX

Status

()

Core
Networking: Cache
P5
enhancement
RESOLVED WONTFIX
18 years ago
15 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Assigned: gordon)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: parity-IE)

per Timeless in IRC (and he can update this bug if I made an error), it'd be 
nice to have a Cache window, and the implementation would be as such:

Double click on an object in a window to open it up (with the right MIME 
type/helper app association).
Highlight the object in the cache window and press delete to delete without a 
prompt.
->networking: cache...?
Assignee: vishy → neeti
Component: XP Apps → Networking: Cache
QA Contact: sairuh → gordon

Comment 2

18 years ago
How about just having about:cache show the location of the cache directory 
(bug 64881, bug 64882)?  I don't think users need to micromanage their cache 
too often.

Comment 3

17 years ago
Cache bugs to Gordon
Assignee: neeti → gordon
Target Milestone: --- → mozilla1.0
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0 → Future

Comment 4

17 years ago
Even without the cache window, it is impossible to decipher the contents of the
cache when the user does navigate to the local cache directory. Could files in
the cache be stored as images, html pages, class files, etc (with appropriate
extensions and intelligible content) so that they can be accessed later...

Comment 5

16 years ago
*** Bug 157262 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Attenton: please see bug 99817, bug 173441.
Alias: CacheExplorer

Comment 7

16 years ago
*** Bug 173441 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Priority: -- → P5
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 8

16 years ago
Perhaps there is no need for a new window/dialog.
"View cached version" rigth click option for entries at history sidebar
may be sufficient.
(Assignee)

Comment 9

16 years ago
Yes, I think the utility of this feature is marginal.  Most users would never
use it, or even know it exists.

Marking WONTFIX.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 10

16 years ago
>> Perhaps there is no need for a new window/dialog.
>> "View cached version" rigth click option for entries at history sidebar
>> may be sufficient.

> Yes, I think the utility of this feature is marginal.  Most users would never
> use it, or even know it exists.

Huh?

I didn't mean that, this feature is NOT needed.
I think it is indeed needed and It can be implemented without major modification
on gui. Just a "View cached version" option can be added to history sidebar
along with some code to fetch cached files to browser.

I'd like to reopen this bug.

Your comments?

Comment 11

16 years ago
well, for the time being, i'd settle for being able to browse from about:cache
through to a cached resource instead of just getting a link to a url which will
probably ignore the cache. can cache at least implement that little?

right now i can get to
about:cache-entry?client=image&sb=0&key=http://bugzilla.mozilla.org/attachment.cgi?id=111028&action=view
but the link it has is to the url instead of to the cached data. 

note that win ie does let you browse the cache and micromanage it. being able to
delete all cache records for a specific host is useful and i'm sure we have
people who would use it.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 12

16 years ago
From Imran Geriskovan's comment 10:

> a "View cached version" option can be added to history sidebar

Please file a new bug and post the bug number here instead of reopening and
morphing this one.  In your bug, you might mention bug 155834, "When offline,
history entries should reflect status in cache".


From timeless's comment 11:

> i'd settle for being able to browse from about:cache through to a cached 
> resource instead of just getting a link to a url which will probably ignore 
> the cache.

Filed bug 188448.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX
Whiteboard: parity-IE

Comment 13

15 years ago
*** Bug 214334 has been marked as a duplicate of this bug. ***
*** Bug 214283 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.