Closed Bug 66310 Opened 19 years ago Closed 19 years ago

bad links not handled in FTP

Categories

(Core :: Networking: FTP, defect)

defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 18007

People

(Reporter: blue, Assigned: dougt)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17 i686; en-US; m18) Gecko/20010122
BuildID:    2001012221

this was orginally reported in bug 39814 - i assume this is a reoccurance of the
same bug.

mozilla hangs and crashes on bad ftp:// links.

Reproducible: Always
Steps to Reproduce:
1. ftp://www.gator.net/foo/bar
2. observe mozilla's zen
3. fix bug :)

Actual Results:  mozilla sits-n-spins

Expected Results:  bad link error

you guys rock, thanks!
Confirmed
Platform: PC
OS: Windows 98
Mozilla Build: 2001012205

Marking NEW.
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking: FTP
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
reassigning
Assignee: asa → dougt
QA Contact: doronr → tever
This is most definately a duplicate...finding...
Knew I encountered this bug before.

It's related to not implementing some part of DNS support.

But have you ever seen it CRASH when it goes to a bad FTP link, or does it
just sit there and spin?

*** This bug has been marked as a duplicate of 18007 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.