animationstart event not fired without animation-delay set.

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
RESOLVED INVALID
7 years ago
a year ago

People

(Reporter: Divya Manian, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Opera/9.80 (Macintosh; Intel Mac OS X 10.6.7; U; en) Presto/2.8.131 Version/11.50
Build Identifier: 6.0.a2

The animationstart event does not seem to be fired in Firefox without an animation-delay. Webkit does fire this event with or without animation-delay set. 

Reproducible: Always

Steps to Reproduce:
1. Visit the url
2. Notice no animationstart text.
3. http://jsfiddle.net/nimbu/pHMgu/8/ has animationstart text

Actual Results:  
No animationevent fired

Expected Results:  
Animationstart event will be fired.

Comment 1

7 years ago
Reproduced:
Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a2) Gecko/20110609 Firefox/6.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110609 Firefox/7.0a1

WFM:
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.24 (KHTML, like Gecko) Chrome/11.0.696.71 Safari/534.24
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → style-system
Status: UNCONFIRMED → NEW
Ever confirmed: true
It appears that the problem is simply that the script doesn't add the event listener until *after* the event has been dispatched.

If I set the style and add the event listener immediately afterwards I see the event: http://jsfiddle.net/pHMgu/15/

I think this is invalid, Divya what do you think?
Flags: needinfo?(divya.manian)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Flags: needinfo?(divya.manian)
You need to log in before you can comment on or make changes to this bug.