Last Comment Bug 663229 - e10s HTTP: initialize prnetaddrs correctly in child
: e10s HTTP: initialize prnetaddrs correctly in child
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla7
Assigned To: Jason Duell [:jduell] (needinfo me)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-09 14:09 PDT by Jason Duell [:jduell] (needinfo me)
Modified: 2013-12-27 14:32 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Approved patch copied from bug 661158 (2.97 KB, patch)
2011-06-09 14:12 PDT, Jason Duell [:jduell] (needinfo me)
jduell.mcbugs: review+
blassey.bugs: approval‑mozilla‑aurora-
Details | Diff | Splinter Review

Description Jason Duell [:jduell] (needinfo me) 2011-06-09 14:09:55 PDT
Spin-off of bug 661158.  Just minor codefix to move some initializers that should now be in HttpBaseChannel, not nsHttpChannel.
Comment 1 Jason Duell [:jduell] (needinfo me) 2011-06-09 14:12:49 PDT
Created attachment 538347 [details] [diff] [review]
Approved patch copied from bug 661158

Copying jdm's +r.

Includes breakpoint to cause parent to crash (intentionally) if we see it trying to pass in a Unix domain socket enum over IPDL.
Comment 2 Jason Duell [:jduell] (needinfo me) 2011-06-09 15:11:35 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/a19e5f55f67c
Comment 3 Mounir Lamouri (:mounir) 2011-06-10 02:55:56 PDT
http://hg.mozilla.org/mozilla-central/rev/a19e5f55f67c
Comment 4 Josh Matthews [:jdm] 2011-07-21 11:22:45 PDT
Comment on attachment 538347 [details] [diff] [review]
Approved patch copied from bug 661158

So, this patch does not actually fix the topcrash that is tracked by bug 661158. In fact, it arguably makes the crash strictly worse, since it changes a content process crash into a browser crash. On the other hand, this change should make us crash at the point when we start sending bad data over the wire, and this is good because Jason and I can't figure out why this would ever happen. Obviously it is, and it's happening fairly frequently, so this kind of data would be valuable to us.
Comment 5 Jason Duell [:jduell] (needinfo me) 2011-07-21 11:25:05 PDT
Comment on attachment 538347 [details] [diff] [review]
Approved patch copied from bug 661158

> this change should make us crash at the point when we start sending bad 
> data over the wire, and this is good 

+1
Comment 6 Asa Dotzler [:asa] 2011-07-21 14:34:33 PDT
We didn't have a mobile rep at today's triage but desktop has no concerns here so I'm delegating the yes/no to which ever of the Mobile drivers gets here first.
Comment 7 Brad Lassey [:blassey] (use needinfo?) 2011-07-22 09:51:56 PDT
Comment on attachment 538347 [details] [diff] [review]
Approved patch copied from bug 661158

since this doesn't actually fix anything I don't think we want to take this. If my understanding is incorrect, please explain and re-nom

Note You need to log in before you can comment on or make changes to this bug.