Scrolling up or down from the keyboard also scrolls to left

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
20 years ago
19 years ago

People

(Reporter: lennox, Assigned: beard)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] erin@imaginet.com, URL)

Attachments

(3 attachments)

(Reporter)

Description

20 years ago
When I scroll up or down with the keyboard in apprunner (using PageUp, PageDown,
or space) on a page which is wider than my current screen, the display jumps so
that it is horizontally scrolled all the way to the left.

I noticed this with the default start-up page,
http://www.mozilla.org/quality/smoketests/, because it lays out somewhat wider
than the the default apprunner window, so I had to scroll to the right to view
the content rather than the Mozilla sidebar.  When I hit page-down, the content
was again half-obscured off the right-hand side of the page.

I don't know if this properly goes in "Layout", but I wasn't sure what other
component would be applicable to it.  (It depends somewhat on what's causing the
problem, I suppose.)

This is a SeaMonkey tree of 05/17/99 11:44:23 PDT, compiled and running on
FreeBSD 3.1-STABLE, configured as "CC=egcc CXX=eg++ ./configure
--enable-mailnews".

Updated

20 years ago
Assignee: rickg → joki

Comment 1

20 years ago
More event/scrolling problems that you may already be aware of. Tom, if these
shouldn't go to you, please let me know.

Updated

19 years ago
Whiteboard: making test erin@imaginet.com

Comment 2

19 years ago
Created attachment 826 [details]
test case for 6633

Comment 3

19 years ago
Created attachment 856 [details]
new test case

Updated

19 years ago
Whiteboard: making test erin@imaginet.com → [TESTCASE] erin@imaginet.com

Comment 4

19 years ago
Separate the scrolling down function from making the horizontal scroll to the
left

Comment 5

19 years ago
Created attachment 861 [details]
scroll test

Updated

19 years ago
Assignee: joki → beard
OS: FreeBSD → All
Hardware: PC → All

Comment 6

19 years ago
reproducible on mac; change platform/os to ALL; reassign to beard and cc michaelp
since they worked on the scrolling code which is where the bug actually is.
ScrollByPages() calls ScrollTo with 0 rather than the current position.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 7

19 years ago
*** Bug 15875 has been marked as a duplicate of this bug. ***
*** Bug 20262 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 9

19 years ago
I can't reproduce this any longer.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
With the latest build (2000010308), the problem is not occuring.

Comment 11

19 years ago
*** Bug 30658 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.