Contribute pop-up on add-on page is off-screen

VERIFIED FIXED in 6.1.2

Status

addons.mozilla.org Graveyard
Public Pages
P1
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: tofumatt, Assigned: Andy McKay)

Tracking

unspecified
6.1.2
x86
All

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 538424 [details]
Screenshot of misaligned contribute popover form

Clicking the "<3 Contribute" link activates a popover, but it appears (partially) off-screen, then jumps around when closed (by click anywhere on the page it isn't occupying). This is happening on addons.allizom.org on Aurora for Mac (6.0.2a).

Steps:

1. Go to https://addons.allizom.org/z/en-US/firefox/addon/tineye-reverse-image-search/contribute/roadblock/?src=creatured&version=1.1
2. Click on the <3 Contribute link
3. Wonder where the popover went!

Expected result:

The popover appears entirely within the browser's viewport (centered).

Actual result:

The popover appears partially out-of-view and cannot be used.

Attached is a screenshot of the actual result.

Comment 1

7 years ago
note: This is on 6.0a2
I can reproduce in a nightly on linux.
Assignee: nobody → amckay
OS: Mac OS X → All
Priority: -- → P1
Target Milestone: --- → 6.1.2

Comment 3

7 years ago
Andy, depending on the funkiness at play here, you can try switching the contribute modal from the current jquery modal to the modal we have in zamboni/global.js- it seems to be working well in Nightly. It also means we get one step closer to throwing that jqm library out!
(Assignee)

Comment 4

7 years ago
Didn't read comment-3 until after, but yes we should be using that.
(Assignee)

Comment 5

7 years ago
https://github.com/jbalogh/zamboni/commit/6f3e8b29b3aa9d4977dcfb3c8dfbbf52619636e8

Bug filed to remove jqmWindow.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 664481

Comment 8

7 years ago
Created attachment 539586 [details]
post-fix screenshot
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.