Closed Bug 663335 Opened 9 years ago Closed 7 years ago

Strange behavior for Google Maps Classic webpage

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: xti, Unassigned)

References

Details

Attachments

(2 files)

Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/201100609
Firefox/7.0a1 Fennec/7.0a1
Device: Motorola Droid 2
OS: Android 2.2

Steps to reproduce:
1. Open Fennec app
2. Have the hardware keyboard opened
3. Go to maps.google.com
4. Tap on Get Directions menu
5. Go to Classic version of Google Maps (long tap on Classic link and open it in a new tab)
6. Tap on Get Directions
7. Type some numbers on "A" input field
8. Pan left/right for side panels
9. Close the hardware keyboard and switch the device to portrait
10. Tap on "B" input field and type anything (ex: NY 1901)

Expected result:
The characters are displayed as you type for A and B input fields. Panning left/right will show up the side panels.

Actual result:
At step 7, numbers can not be typed. 
At step 8, panning is not working or it might work, but after many tries. 
At step 9, the map edges are not re-sized after the device is switched to portrait mode. Map borders remains the same at it were for landscape mode. 
At step 10, the B input field is blue highlighted, but is not zoomed in and is not in focus. Also virtual keyboard is not fired after the hardware keyboard is closed.

Notes:
This bug is reproducing only for devices with a hardware keyboard opened.
Please see the following video: http://www.youtube.com/user/qaioana#p/a/u/0/uz49HvQT5zA
Depends on: 655212
Hrm.  I wonder what the CPU and memory utilization is during the time that we see this.  Are there any 3rd party CPU/memory utilization tools you can install?  Or perhaps doing this while logging with ddms?
Priority: -- → P3
After I've opened Fennec, I let the device alone for a couple of minutes until CPU & Memory were steady. Here are the results:
- CPU utilization: ~14-25% (sometimes CPU goes up to ~40-98% - maybe because of running apps in background)
- RAM utilization: ~95-100 Mb free

Results while performing step 7:
- CPU utilization: ~48-68%
- RAM utilization: ~68-70% Mb free

Results while performing step 8:
- CPU utilization: ~70-100%
- RAM utilization: ~68-75% Mb free

Note:
Before logging any data, I've killed all app opened on my device (Motorola Droid 2).
I've used the following 3rd party apps: SysMonitor (for CPU/Memory live utilization), aLogcat, Android System Info (both for saving logs).
Priority: P3 → --
Attached file ddms log
Attached file aLogcat log
"At step 10, the B input field is blue highlighted, but is not zoomed in and is not in focus. Also virtual keyboard is not fired after the hardware keyboard is closed."

This is bug 670974. Narrow down this bug to specific bugs, or create other specific bugs.
Depends on: 670974
No longer depends on: 655212
Depends on: 655212
Depends on: 671273
Is this still an issue? If not, please mark WFM.
It's not an issue anymore for Firefox for Android. Closing bug as WFM.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.