Last Comment Bug 663378 - Intermittent failure in layout/style/test/test_acid3_test46.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - runTest is not defined at http://mochi.test:8888/tests/layout/style/test/test_acid3_test46.html:1
: Intermittent failure in layout/style/test/test_acid3_test46.html | [SimpleTes...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All Windows XP
: -- normal (vote)
: mozilla10
Assigned To: Phil Ringnalda (:philor)
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2011-06-10 07:01 PDT by Mounir Lamouri (:mounir)
Modified: 2014-10-15 12:03 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix v.1 (1.15 KB, patch)
2011-10-21 23:32 PDT, Phil Ringnalda (:philor)
dbaron: review+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2011-06-10 07:01:57 PDT
s: talos-r3-xp-058
4531 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_acid3_test46.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - runTest is not defined at http://mochi.test:8888/tests/layout/style/test/test_acid3_test46.html:1

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307703855.1307704936.8430.gz&fulltext=1
Comment 1 Treeherder Robot 2011-06-11 13:48:25 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Jaegermonkey/1307818970.1307819452.470.gz
Rev3 WINNT 5.1 jaegermonkey opt test mochitests-4/5 on 2011/06/11 12:02:50

s: talos-r3-xp-013
4521 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_acid3_test46.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - runTest is not defined at http://mochi.test:8888/tests/layout/style/test/test_acid3_test46.html:1
Comment 2 Treeherder Robot 2011-06-15 02:42:02 PDT
smontagu%smontagu.org
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1308129644.1308130103.20234.gz
Rev3 WINNT 5.1 mozilla-central opt test mochitests-4/5 on 2011/06/15 02:20:44

s: talos-r3-xp-041
4500 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_acid3_test46.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - runTest is not defined at http://mochi.test:8888/tests/layout/style/test/test_acid3_test46.html:1
Comment 3 Treeherder Robot 2011-06-15 23:13:06 PDT
mwu%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308203277.1308203995.27735.gz
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-4/5 on 2011/06/15 22:47:57

s: talos-r3-xp-055
4534 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_acid3_test46.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - runTest is not defined at http://mochi.test:8888/tests/layout/style/test/test_acid3_test46.html:1
Comment 4 Treeherder Robot 2011-10-11 11:19:42 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=6790479&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-4/5 on 2011-10-11 10:35:09

4640 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_acid3_test46.html | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: runTest is not defined at http://mochi.test:8888/tests/layout/style/test/test_acid3_test46.html:1
Comment 5 Treeherder Robot 2011-10-15 10:42:55 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=6870855&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound pgo test mochitests-4/5 on 2011-10-15 06:56:59

4635 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_acid3_test46.html | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: runTest is not defined at http://mochi.test:8888/tests/layout/style/test/test_acid3_test46.html:1
Comment 6 Treeherder Robot 2011-10-21 23:22:56 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=6979872&tree=Mozilla-Aurora
Rev3 WINNT 5.1 mozilla-aurora pgo test mochitests-4/5 on 2011-10-21 20:57:53

4569 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_acid3_test46.html | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: runTest is not defined at http://mochi.test:8888/tests/layout/style/test/test_acid3_test46.html:1
Comment 7 Phil Ringnalda (:philor) 2011-10-21 23:32:55 PDT
Created attachment 568850 [details] [diff] [review]
Fix v.1

It puts the function definition before the onload that calls it, or it gets the failure again.
Comment 8 Treeherder Robot 2011-10-27 13:42:55 PDT
mbrubeck%mozilla.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=7066699&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-4/5 on 2011-10-27 13:26:03

4699 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_acid3_test46.html | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: runTest is not defined at http://mochi.test:8888/tests/layout/style/test/test_acid3_test46.html:1
Comment 9 Treeherder Robot 2011-10-27 13:43:28 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=7066699&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-4/5 on 2011-10-27 13:26:03

4699 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/style/test/test_acid3_test46.html | [SimpleTest/SimpleTest.js, window.onerror] - An error occurred: runTest is not defined at http://mochi.test:8888/tests/layout/style/test/test_acid3_test46.html:1
Comment 10 David Baron :dbaron: ⌚️UTC-10 2011-10-28 12:09:16 PDT
Comment on attachment 568850 [details] [diff] [review]
Fix v.1

This seems ok, but I don't think it's actually the problem.

I think the problem is that https://hg.mozilla.org/mozilla-central/rev/3f20f058583c did not add SimpleTest.waitForExplicitFinish() and SimpleTest.finish() calls, so much of the time the test doesn't test anything at all, but if the timing's just right, it manages to run things in the middle of unloading.
Comment 11 Phil Ringnalda (:philor) 2011-10-29 12:36:45 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/5321cee08f41

I couldn't find any evidence of us either running no tests or only part of the tests, but my interest in loading full logs waned pretty quickly, so I just threw in the waitForExplicit/finish to be sure it wouldn't be a problem.
Comment 12 David Baron :dbaron: ⌚️UTC-10 2011-10-29 12:55:55 PDT
Looks good.
Comment 13 Ed Morley [:emorley] 2011-10-30 10:35:58 PDT
https://hg.mozilla.org/mozilla-central/rev/5321cee08f41

Note You need to log in before you can comment on or make changes to this bug.