Web Console window is moving when dragging main Firefox window

RESOLVED INVALID

Status

()

Firefox
Developer Tools: Console
--
minor
RESOLVED INVALID
7 years ago
4 years ago

People

(Reporter: Aleksej, Unassigned)

Tracking

5 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [linux-only in a new feature] [fx6][testday-20110610])

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 538509 [details]
Screencast of the bug

Aurora nightly: Mozilla/5.0 (X11; Linux x86_64; rv:6.0a2) Gecko/20110609 Firefox/6.0a2

Steps to reproduce:
1. Open the Web Console (Ctrl+Shift+K)
2. Click "Position" and choose "Window" to make it a separate window.
3. Drag main Firefox window.

Actual results:
Web Console is moving to the bottom of the screen, and a little left-and-right, depending on the dragging.

Expected results:
Web Console is not moving.  If it is intended to move in some way, it may be a problem when using a tiling window manager like xmonad.


Operating system details:
* Debian Squeeze-Wheezy
* GNOME and Metacity ≈2.30
* GTK 2.24
(Reporter)

Updated

7 years ago
tracking-firefox6: --- → ?
Whiteboard: [testday-20110610] → [fx6][testday-20110610]
Speculatively tracking-firefox-6+ on this because it looks like a regression as a result of firefox-6-specific changes - we need to understand pretty quickly whether this is trivially fixable, or whether we should back out the change that caused it.

Rob,Mihai,Kevin  - can we get some analysis here?
tracking-firefox6: ? → +
(In reply to comment #1)
> Speculatively tracking-firefox-6+ on this because it looks like a regression
> as a result of firefox-6-specific changes - we need to understand pretty
> quickly whether this is trivially fixable, or whether we should back out the
> change that caused it.
> 
> Rob,Mihai,Kevin  - can we get some analysis here?

The problem is caused by the toolkit XUL widget we use, most specifically by the xul:panel implementation which has some bugs. Issues with xul:panels are known to us.

A fix would be needed in the platform layer. Having experience only with the front end code I cannot estimate the complexity of a fix.
Adding Neil. This behaviour looks really wonky, we need to understand whether there is an aurora-safe fix we can take here, or whether we need to back out/disable the feature that made this possible.

Comment 4

7 years ago
To add some context around this, this problem surfaces on Linux only and is only an issue if the user pops the console out into a separate window (one of the new options). A fix for this would be terrific.

On the flip side, though, the ability to reposition the console was the #1 web console request on input.mo during the Firefox 4 cycle (some people wanted the console in a separate window, others wanted it at the bottom of the window).

I would hate to lose the positioning feature in 6 because of this bug which only affects Linux users and only in the new "Window" position.

Comment 5

7 years ago
(In reply to comment #2)

> The problem is caused by the toolkit XUL widget we use, most specifically by
> the xul:panel implementation which has some bugs. Issues with xul:panels are
> known to us.

What issues?

Since I can't reproduce this bug, it seems unlikely to be a panel issue. It looks like it might be a window manager issue. The video suggests that the size of the titlebar is being counted twice or not at all in some manner.

Does it happen only on some Linux environments?

It doesn't seem to happen for me in a stock Ubuntu 11 environment.

Comment 6

7 years ago
(In reply to comment #5)
> Does it happen only on some Linux environments?
> 
> It doesn't seem to happen for me in a stock Ubuntu 11 environment.

Happens for me with Ubuntu 11.04 + Xfce 4
(In reply to comment #5)
> (In reply to comment #2)
> 
> > The problem is caused by the toolkit XUL widget we use, most specifically by
> > the xul:panel implementation which has some bugs. Issues with xul:panels are
> > known to us.
> 
> What issues?

For example moveTo() and sizeTo() do not always work as advertised. We get random jumping, random small differences in the expected behavior. moveTo() doesn't always position the panel where we want (it's sometimes a few pixels off). sizeTo() causes the popup to move a few pixels at times, and related problems.

If I resize the panel (as a user, not from the code), I get a bit of panel movement as well. If I drag the panel and stop drag, then move the mouse, the panel jumps a bit.

Due to these problems I barely wrote a mochitest that doesn't fail on my system and on the try server. Had to do some funky stuff to avoid failures.

(funky, as in ... never expect that after a moveTo(x,y) call the popup panel is going to be exactly at the given x, y coords.)


> Since I can't reproduce this bug, it seems unlikely to be a panel issue. It
> looks like it might be a window manager issue. The video suggests that the
> size of the titlebar is being counted twice or not at all in some manner.
> 
> Does it happen only on some Linux environments?
> 
> It doesn't seem to happen for me in a stock Ubuntu 11 environment.

I don't always have these issues. I'm on Gnome, Metacity, Ubuntu 10.04. It's just that in some cases, some environments, we have such problems.

Comment 8

7 years ago
Created attachment 539880 [details] [diff] [review]
debugging log patch

This patch prints a pile of debugging logging to stdout. If someone who can reproduce this bug could try this, I might be able to debug.

1. Apply the patch
2. Open the console and click on some blank area so that the textbox isn't focused.
3. Press the 'a' key.
4. Test out the bug
5. Press the 'a' key when done
6. Send me the log

The key pressing is there just to dump out a separator so I can find the output in the log.
ddahl: can you please try to repro with the debug patch? Thank you!

(I cannot repro with the given STR, and the problems I talked about are "random" - not specific cases I can point now, in this context.)

Updated

7 years ago
Whiteboard: [fx6][testday-20110610] → [linux-only in a new feature] [fx6][testday-20110610]

Comment 10

7 years ago
We're going to live with this in 6 unless we get tons of beta feedback saying this is a major pain point

Updated

7 years ago
tracking-firefox7: --- → +

Comment 11

7 years ago
I think we can turn off the tracking flags for this. I haven't seen *any* feedback for this yet, and the problem does not seem consistently reproducible. We can re-request tracking if we think this has turned into something with a greater impact, but we can't even start working on a fix until someone can reproduce the problem with Neil's patch applied.
tracking-firefox6: + → ---
tracking-firefox7: + → ---
(Reporter)

Comment 12

7 years ago
It is reproducible with xmonad 0.9.2.

It does interfere with window management:
* window jumps to a (remarkable, but not very bad) different position at some movements;
* when windows are tiled, when they are supposed to be in a row, they are in a column, like with the other tiling mode, and then cannot be resized;
but not at all like what Inspector was doing in the past. Confusing and thus annoying, but not very harmful.

Comment 13

7 years ago
Thanks for the info Aleksej. We'll likely have more features that are able to pop out into separate windows (XUL panels, actually), so this could affect more than just the Web Console (at least for the small proportion of people running Linux and xmonad)

We still need someone to run Firefox on xmonad with Neil's patch in order to get the info together for a fix.
(Reporter)

Comment 14

6 years ago
Still reproducible with Nightly 20120830030531 Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/18.0 Firefox/18.0, the window can get out of screen (although probably only intentionally).

Comment 15

5 years ago
triage. Filter on PINKISBEAUTIFUL
Component: Developer Tools → Developer Tools: Console
This is no longer a valid bug. The developer tools toolbox landed. The Web Console no longer uses a xul:panel of its own.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.