Make an option to scroll search engines with mouse wheel without pressing a key

RESOLVED DUPLICATE of bug 417413

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 417413
8 years ago
6 years ago

People

(Reporter: vfede, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:7.0a1) Gecko/20110609 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:7.0a1) Gecko/20110609 Firefox/7.0a1

It's not possible to scroll between different search engines with the mouse wheel without pressing the Accel key on the keyboard

Reproducible: Always


Actual Results:  
It is possible to scroll the different search engines in the search bar when is focused with Accel+UP/DOWN or by pressing Accel(Ctrl/Cmd) and scrolling with the mouse wheel when hovering on the bar.

Expected Results:  
It is possible to scroll search engines also without pressing the Accel key for the mouse only interaction.

I think that this option could be a good default for switching faster between search engines, but I will understand if the current behaviour will remain the default. I think that an option in the about:config could be a good solution.

I don't think that don't pressing a key will accidentally trigger the event and confuse the user, because he can do this only when hovering on the search bar: currenlty the user does not have any other intention when scrolling on the search bar and no other behaviour by the bar is expected other than scrolling between search engines.

Comment 1

7 years ago
In my opinion this is an enhancement and not a bug. Can you please change the importance accordingly.
Thx

Updated

6 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 417413
You need to log in before you can comment on or make changes to this bug.