when a url is IP address the login button don't work !

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: payments, Unassigned)

Tracking

4.0 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0

Hello,
when i want to login to some websites (control panels) they are IP based in url and don't have domain name the login button don't work.
such as https://173.208.88.52:8443/vz/cp/panel/plesk/frameset or https://85.17.74.14:2083/ 
Its simple login form and only needs username & password... but after i replace it with a domain name or i use another browser its work perfectly.

Best Regards


Reproducible: Always

Steps to Reproduce:
1.open browser
2.go to https://173.208.88.52:8443/vz/cp/panel/plesk/frameset
3.enter username & password after press enter or press login by mouse nothing happening.

Actual Results:  
Actual results is No Thing ! Nothing will happened after i press login.

Expected Results:  
IE Chrome Opera

There is nothing special installed on my Ubuntu.
Actually its fresh Ubuntu and i install it few days ago.

Updated

8 years ago
Severity: major → normal
Component: Developer Tools → General
QA Contact: developer.tools → general

Comment 1

8 years ago
WFM in Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Try a build from mozilla and see if it works there?

http://releases.mozilla.org/pub/mozilla.org/firefox/releases/latest-4.0/linux-x86_64/en-US/
Severity: normal → major
Component: General → Developer Tools
(Reporter)

Comment 2

8 years ago
Hello,
I install 4.0.1 using synaptic manager but still same problem....


Regards
(Reporter)

Comment 3

8 years ago
One more thing... I find out this problem only happening when using httpS and its not happening for http IP based url.

Regards

Comment 4

8 years ago
Not a developer tools problem. Moving to General. Also there is an existing workaround (use the internet address instead of the IP number) downgrading severity to normal.

> One more thing... I find out this problem only happening when using httpS and
> its not happening for http IP based url.
This is expected. The Security Certificates are invalid for IP numbers.

For the first link:

173.208.88.52:8443 uses an invalid security certificate.

The certificate is not trusted because it is self-signed.
The certificate is only valid for VZCP
The certificate expired on 20/04/2011 8:42 AM.

(Error code: sec_error_expired_issuer_certificate)

For the second link:

85.17.74.14:2083 uses an invalid security certificate.

The certificate is not trusted because it is self-signed.
The certificate is only valid for TJ013.bestvzserver.com

(Error code: sec_error_untrusted_issuer)

Resolving as INVALID because Firefox is working as expected.
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: Developer Tools → General
Resolution: --- → INVALID
Version: unspecified → 4.0 Branch
(Reporter)

Comment 5

8 years ago
I confirm security certificate.
The page load successfully but only login button don't work...
Everybody use Cpanel and Parallels Virtuozzo (Plesk) also its works on my windows Firefox or any other browsers...
Again I confirm security certificate as trusted... so shouldn't it work ?!

Regards
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 6

8 years ago
Also https://ns12.poshtiban.net:2087/ = https://85.17.74.14:2087/  and they have same SSL certificate... if its certificate problem why workes for the first one and don't work for second one ?!

Regards
(Reporter)

Comment 7

8 years ago
I should tell you its self-signed certificate and many website and website using that way and we both know it.
That is why we should confirm it with our own risk in firefox.
The certificate is invalid for both ip or domain but the problem is something else as i confirm it as trusted....

Regards
The certificate for https://173.208.88.52:8443 is both expired (in April) and has a bogus CN ("VZCP").

Firefox's behavior is correct. I suggest you contact your hosting provider for help on how to configure SSL.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.