cannot type in address bar if drop-down list with 2+ options appears and is ignored

VERIFIED FIXED

Status

SeaMonkey
Location Bar
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Cormac F, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Okay, steps to reproduce:

1) Got a site and visit a number of pages e.g. go to www.ireland.com followed 
by www.ireland.com/services/email

2) Go to any other site

3) Click in the address bar, delete whats there, and begin to type in the 
original site name e.g. www.ireland.com

4) The drop down list will appear and the rest of the address will highlight. 
Ignore this and continue typing

5)When you finish typing the address, the cursor will jump forward a little and 
the first item in the drop-down list will remain highlighted.

6) Press and hold the delete key. You can't delete the text

You have to highlight it with  your mouse pointer to delete.
Admittedly, a minor enough bug, but they all count.
Using build 200101304 on WinNT4

Comment 1

17 years ago
I've seen this, too, but it doesn't always happen.  It seems like sometimes,
after the dropdown list appears, I *can* use delete or type more characters in
the URL bar.

Comment 2

17 years ago
->Editor
Assignee: asa → beppe
Status: UNCONFIRMED → NEW
Component: Browser-General → Editor
Ever confirmed: true
QA Contact: doronr → sujay,shrir

Comment 3

17 years ago
sounds liek this is a xp apps bug, assigning to vishy
Assignee: beppe → vishy
Component: Editor → XP Apps
QA Contact: sujay,shrir → sairuh
(Reporter)

Updated

17 years ago
Summary: cannot delete text in address bar if drop-down list appears and is ignored → cannot type in address bar if drop-down list with 2+ options appears and is ignored
(Reporter)

Comment 4

17 years ago
changed the summary. You can't type anything if you follow the steps outlined 
below. Which amkes this a bit more important. 
Feel free to change the summary if I havn't simplified it down enough.

Comment 5

17 years ago
over to alecf, history/urlbar
Assignee: vishy → alecf
Component: XP Apps → History: URLBar
QA Contact: sairuh → claudius

Comment 6

17 years ago
this is a autocomplete bug, reassign to ducarroz (I don't know who owns this),
keeping myself on the cc
Assignee: alecf → ducarroz
(Reporter)

Comment 7

17 years ago
I imagine this bug is redundant, with the new autocomplete now working(mostly)?
reassign to hewitt
Assignee: ducarroz → hewitt
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 9

17 years ago
Can't replicate this with the new widget
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.