[HW Acc] Acid2 test image rendering differences and some warnings

VERIFIED WORKSFORME

Status

()

Core
Graphics
--
major
VERIFIED WORKSFORME
6 years ago
25 days ago

People

(Reporter: Virtual, Unassigned)

Tracking

(Blocks: 1 bug, {nightly-community, regression})

2.0 Branch
All
Windows 7
nightly-community, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:7.0a1) Gecko/20110610 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:7.0a1) Gecko/20110610 Firefox/7.0a1

Errors from error console:

Warning: Expected ']' to terminate attribute selector but found 'two'.  Ruleset ignored due to bad selector.
Source File: http://www.webstandards.org/files/acid2/test.html#top
Line: 43

Warning: Unknown property 'error'.  Declaration dropped.
Source File: http://www.webstandards.org/files/acid2/test.html#top
Line: 94

Warning: Unknown property 'm
rgin'.  Declaration dropped.
Source File: http://www.webstandards.org/files/acid2/test.html#top
Line: 97

Warning: Selector expected.  Ruleset ignored due to bad selector.
Source File: http://www.webstandards.org/files/acid2/test.html#top
Line: 98

Warning: Error in parsing value for 'width'.  Declaration dropped.
Source File: http://www.webstandards.org/files/acid2/test.html#top
Line: 99

Warning: Expected 'important' but found 'error'.  Expected ';' or '}' to terminate declaration but found 'error'.  Declaration dropped.
Source File: http://www.webstandards.org/files/acid2/test.html#top
Line: 100

Warning: Error in parsing value for 'background'.  Declaration dropped.
Source File: http://www.webstandards.org/files/acid2/test.html#top
Line: 101

Error: An error occurred updating the cmd_selectAll command: [Exception... "'[JavaScript Error: "this._view.result is null" {file: "chrome://browser/content/places/controller.js" line: 179}]' when calling method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 80"  data: yes]
Source File: chrome://global/content/globalOverlay.js
Line: 86

Reproducible: Always
Blocks: 289480
Keywords: regression
Created attachment 538713 [details]
HW Acc - ON.png
Created attachment 538714 [details]
HW Acc - OFF.png
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Concerning the Warnings/Errors, you repro'd this without ABP Usage (deinstalling, not just disabling), too?
I tested this without ABP and got 1 error less (the last one), so I only see warnings.
I also test this in Firefox 5 b5 Portable and got same results.
Hardware: x86_64 → All
Version: unspecified → 2.0 Branch
Summary: [HW Acc] Acid2 test errors and image rendering differences → [HW Acc] Acid2 test image rendering differences and some warnings

Comment 5

6 years ago
> Error: An error occurred updating the cmd_selectAll command: [Exception...
> "'[JavaScript Error: "this._view.result is null" {file:
> "chrome://browser/content/places/controller.js" line: 179}]' when calling
> method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021
> (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame ::
> chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 80" 
> data: yes]
> Source File: chrome://global/content/globalOverlay.js
> Line: 86

Is this the error you are referring to? 
I don't see it on the latest Firefox Nightly:
Mozilla/5.0 (Windows NT 6.1; rv:7.0a1) Gecko/20110620 Firefox/7.0a1
Can you check to see if it's still there (without the ABP)? Thanks
Created attachment 541001 [details]
HW Acc - ON

Like I said before, error isn't seen when AdBlock Plus is disabled.

But still there are some warnings and image difference.
Attachment #538714 - Attachment is obsolete: true
Attachment #538714 - Attachment is obsolete: false
Attachment #541001 - Attachment description: HW Acc - OFF → HW Acc - ON
Attachment #541001 - Attachment filename: HW Acc - OFF.png → HW Acc - ON.png
Attachment #538713 - Attachment is obsolete: true
It still happen on Firefox 12.0a1pre
Can someone look into this, because it's still marked as unconfirmed
Do you use any non-standard layers/gfx Settings?

  Application Basics

        Name
        Firefox

        Version
        12.0a1

        User Agent
        Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:12.0a1) Gecko/20120123 Firefox/12.0a1

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        Adblock Plus
        2.0.4a.3407
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        Close Duplicate Tabs
        0.4
        true
        closeduplicatetabs@clustergeek

        DownThemAll! *nightly*
        3.0b1pre.20120123.3012
        true
        dta@downthemall.net

        Element Hiding Helper for Adblock Plus
        1.2rc.388
        true
        elemhidehelper@adblockplus.org

        Session Manager
        0.7.8.1
        true
        {1280606b-2510-4fe0-97ef-9b5a22eafe30}

  Important Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage
        http://www.virtualfox.yoyo.pl/

        browser.startup.homepage_override.buildID
        20120123031112

        browser.startup.homepage_override.mstone
        rv:12.0a1

        browser.tabs.tabClipWidth
        1

        extensions.lastAppVersion
        12.0a1

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        104858

        privacy.clearOnShutdown.cache
        false

        privacy.clearOnShutdown.cookies
        false

        privacy.clearOnShutdown.history
        false

        privacy.clearOnShutdown.offlineApps
        true

        privacy.clearOnShutdown.passwords
        true

        privacy.clearOnShutdown.siteSettings
        true

        privacy.cpd.extensions-dta
        true

        privacy.cpd.extensions-sessionmanager
        false

        privacy.cpd.offlineApps
        true

        privacy.cpd.siteSettings
        true

        privacy.sanitize.migrateFx3Prefs
        true

        privacy.sanitize.sanitizeOnShutdown
        true

        privacy.sanitize.timeSpan
        0

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        NVIDIA GeForce GTX 460 v2

        Vendor ID
        0x10de

        Device ID
        0x1205

        Adapter RAM
        1024

        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

        Driver Version
        8.17.12.9053

        Driver Date
        12-17-2011

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7601.17563)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        Google Inc. -- ANGLE (NVIDIA GeForce GTX 460 v2) -- OpenGL ES 2.0 (ANGLE 1.0.0.930)

        GPU Accelerated Windows
        1/1 Direct3D 10

        AzureBackend
        direct2d
awww, I should edit this to look normal... ;p
yep, I use default graphic settings
(In reply to XtC4UaLL [:xtc4uall] from comment #8)
> Do you use any non-standard layers/gfx Settings?

So XtC4UaLL could you reproduce this bug maybe on your system ?
Nope, I failed on 3 Systems (GPU1: NVIDIA 330M; GPU2: ATI Radeon X1950; GPU3: ATI Radeon HD 4850) each using Windows 7.
Odd, it happens for me every time, even in Portable PaleMoon 32bit and 64bit.
But these warnings in console are showing in your case maybe?

Comment 14

5 years ago
Warnings on the console are due to errors on the CSS file from the acid2 website itself.
Check it on : http://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Facid2.acidtests.org%2F&profile=css3&usermedium=all&warning=1

Typos & errors.

I didn't reproduce your display problems on a win8 / FF 17.0.1 (graphics card : AMD HD 7850)
I can't reproduce any image differences anymore with latest Nightly, so I'm closing it as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
Keywords: nightly-community
QA Contact: Virtual
You need to log in before you can comment on or make changes to this bug.