Closed Bug 663657 Opened 8 years ago Closed 4 years ago

Intermittent Android "command timed out: 2400 seconds without output, attempting to kill"

Categories

(Core :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox16 --- affected
firefox17 --- affected
firefox18 --- affected
firefox19 --- affected

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure)

Could be related to (or a duplicate of) bug 662468, or not. Could be caused by bug 508128, or not. Could be Fennec's fault, or httpd.js's fault, or the harness' fault, or not.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307822146.1307828016.28467.gz
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1307708145.1307710574.10368.gz is perhaps not the same thing, since it doesn't have the harness 2400 second timeout.
Could be the same problem in crashtests, or not.

http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308772254.1308775837.16701.gz
Summary: Frequent timeouts running reftests on Android → Frequent timeouts running reftests and crashtests on Android
https://tbpl.mozilla.org/php/getParsedLog.php?id=7689691&tree=Mozilla-Inbound
REFTEST TEST-START | http://10.250.48.218:30165/tests/content/xul/templates/src/crashtests/329335-1.xul | 373 / 986 (37%)
REFTEST TEST-PA
command timed out: 2400 seconds without output, killing pid 18659
https://tbpl.mozilla.org/php/getParsedLog.php?id=7690429&full=1&branch=mozilla-inbound
REFTEST TEST-KNOWN-FAIL | http://10.250.48.213:30115/tests/layout/reftests/forms/progress/bar-pseudo-element-vertical-rtl.html | (SKIP)
REFTEST TEST-KNOWN-Fbefore 401408, after 401408, break 057b3000
before 401408, after 401408, break 057b3000
https://tbpl.mozilla.org/php/getParsedLog.php?id=7707651&tree=Firefox
REFTEST TEST-START | Shutdown

INFO | automation.py | Application ran for: 0:13:11.786549
INFO | automation.py | Reading PID log: /tmp/tmpWROGZHpidlog
getting files in '/mnt/sdcard/tests/reftest/profile/minidumps/'
WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!

REFTEST INFO | runreftest.py | Running tests: end.
Depends on: 721409
https://tbpl.mozilla.org/php/getParsedLog.php?id=9014082&tree=Mozilla-Aurora (woo, first time a native C1 has run visible on Aurora!)
I hid C1 on mozilla-inbound and mozilla-central.
https://tbpl.mozilla.org/php/getParsedLog.php?id=9225390&tree=Mozilla-Aurora (just when I was thinking I might change the summary to only include crashtests, or even only C1)
https://tbpl.mozilla.org/php/getParsedLog.php?id=9234039&tree=Mozilla-Inbound
REFTEST TEST-START | http://10.250.48.214:30150/tests/content/xul/document/crashtests/468211-1.xul | 375 / 671 (55%)
REFTEST TEST-PASS | http://10.250.48.214:30150/tests/content/xul/document/crashtests/468211-1.xul | (LOAD ONLY)
REFTEST INFO | Loading a blank page
REFTEST TEST-START | http://10.250.48.214:30150/tests/content/xul/document/crashtests/468211-2.xul | 376 / 671 (56%)
REFTEST TEST-PASS | http://10.250.48.214:30150/tests/content/xul/document/crashtests/468211-2.xul | (LOAD ONLY)
REFTEST INFO | Loading a blank page
REFTEST TEST-START | http://10.250.48.214:30150/tests/co
command timed out: 2400 seconds without output, killing pid 84365
process killed by signal 9
program finished with exit code -1
elapsedTime=2551.271701
TinderboxPrint: crashtest-1<br/><em class="testfail">T-FAIL</em>
buildbot.slave.commands.TimeoutError: command timed out: 2400 seconds without output, killing pid 84365

https://tbpl.mozilla.org/php/getParsedLog.php?id=9233608&tree=Mozilla-Inbound
REFTEST TEST-START | http://10.250.48.213:30109/tests/content/xul/document/crashtests/468211-1.xul | 375 / 671 (55%)
REFTEST TEST-PASS | http://10.250.48.213:30109/tests/content/xul/document/crashtests/468211-1.xul | (LOAD ONLY)
REFTEST INFO | Loading a blank page
REFTEST TEST-ST
command timed out: 2400 seconds without output, killing pid 44231
process killed by signal 9
program finished with exit code -1
elapsedTime=2496.944548
TinderboxPrint: crashtest-1<br/><em class="testfail">T-FAIL</em>
buildbot.slave.commands.TimeoutError: command timed out: 2400 seconds without output, killing pid 44231