Last Comment Bug 663680 - Invisible gap between zoomed html elements
: Invisible gap between zoomed html elements
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 2.0 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 646757
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-12 01:57 PDT by CoolCmd
Modified: 2014-01-16 08:19 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test page for first comment. (826 bytes, text/html)
2011-06-12 01:58 PDT, CoolCmd
no flags Details

Description CoolCmd 2011-06-12 01:57:16 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Firefox 4.0.1

When page is zoom-in or zoom-out, sometimes between elements there are invisible 1 pixel wide gaps. See test page.

Reproducible: Always

Steps to Reproduce:
1.open test page
2.hit Ctrl-+
3.slowly drag mouse above red line few times
4.background color was changed
5.if background color was not changed, repeat from step 2


Expected Results:  
Color never should change.

I don't see this bug in FF 3.6, Chrome and Opera.
Comment 1 CoolCmd 2011-06-12 01:58:49 PDT
Created attachment 538741 [details]
Test page for first comment.
Comment 2 (mostly gone) XtC4UaLL [:xtc4uall] 2011-06-12 07:19:19 PDT
WFM against Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110610 Firefox/7.0a1 ID:20110610030736 & Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1 ID:20110413222027.

Is your Issue reproducible when you disable the Hardware Acceleration under Options/Advanced/General and restart Firefox?
Comment 3 CoolCmd 2011-06-12 07:37:34 PDT
(In reply to comment #2)
> Is your Issue reproducible when you disable the Hardware Acceleration under
> Options/Advanced/General and restart Firefox?
Yes.
Comment 4 Boris Zbarsky [:bz] 2011-06-12 14:01:16 PDT
roc fixed this recently, iirc...
Comment 5 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-12 18:53:13 PDT
Should be fixed on trunk by bug 646757
Comment 6 AndreiD[QA] 2011-06-21 02:12:49 PDT
Build: Mozilla/5.0 (Windows NT 6.1; rv:7.0a1) Gecko/20110620 Firefox/7.0a1

The issue is not reproducible anymore on the latest Firefox Nightly, after the fix in bug 646757. Setting status to resolved. If you can still see the issue, feel free to reopen the bug. Thanks
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-21 02:14:03 PDT
Thanks for verifying, AndreiD. Since we know what fixed it, FIXED is the appropriate resolution.

Note You need to log in before you can comment on or make changes to this bug.