If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Order of calendars in the Calendar pane is not preserved

RESOLVED DUPLICATE of bug 696334

Status

Calendar
Calendar Views
--
minor
RESOLVED DUPLICATE of bug 696334
6 years ago
5 years ago

People

(Reporter: florian.rathgeber, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.17) Gecko/20110516 Lightning/1.0b2 Thunderbird/3.1.10

Lightning allows reordering calendars in the "Calendar" pane. However, this order is not preserved when restarting thunderbird.

Reproducible: Always

Steps to Reproduce:
1. reorder you calendars in the Calendar pane
2. restart thunderbird


Actual Results:  
The order is back to some default ordering.

Expected Results:  
My custom order is preserved.

On restarting thunderbird, the error console shows the following error 3 times (not sure if this is at all related):

Error: Parser Error. Could not find 'VCALENDAR' component in: 
null
Stack: 
1: [file:///home/fr710/.thunderbird/Profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/fr710/.thunderbird/Profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calIcsParser.js:91] ip_processIcalComponent
2: [file:///home/fr710/.thunderbird/Profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/fr710/.thunderbird/Profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calIcsParser.js:232] parseString_done
3: [file:///home/fr710/.thunderbird/Profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm:165] response_run

Comment 1

6 years ago
Reordering calendars and preserving the order works just fine for me using Lightning/1.0b2 with Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.17) Gecko/20110414 Thunderbird/3.1.10.

The error message indicates that one or more of your calendars is broken, i.e. they don't contain correct iCalendar data. Maybe you can fix or disable them and afterwards Lightning might startup correctly.
(Reporter)

Comment 2

6 years ago
It may be related to another problem: often (particularly when thunderbird had been running longer, i.e. several days) the thunderbird process isn't terminated when I exit and I have to kill it. In these cases I'm seeing the bug. Just now I restarted thunderbird without having to kill the process and the ordering was preserved.

Comment 3

5 years ago
The issue of this is reported in bug #696334 as well. However, there without the parser error thus duping to that one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 696334
You need to log in before you can comment on or make changes to this bug.