Closed Bug 663705 Opened 10 years ago Closed 9 years ago

Add more info about plug-ins to Add-ons Manager, drop about:plugins

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 619652

People

(Reporter: rimas, Unassigned)

Details

(Whiteboard: uiwanted)

The information currently shown in about:plugins partially overlaps with that in the Add-ons Manager. Why not just merge the rest of it into the Add-ons Manager and drop about:plugins for good?

What's still not shown in the Add-ons manager:
* plugin's supported MIME types – could be incorporated into its "More info" page.
* plugin's file name – could also be incorporated into its "More info" page.
* links to https://pfs.mozilla.org/plugins/ and http://plugindoc.mozdev.org/ – could be moved into the top or bottom of Add-ons Manager's Plugins page – just like the link to http://www.mozilla.com/plugincheck/ is already there.
OS: Linux → All
Hardware: x86 → All
(In reply to comment #0)
> The information currently shown in about:plugins partially overlaps with
> that in the Add-ons Manager. Why not just merge the rest of it into the
> Add-ons Manager and drop about:plugins for good?

The two serve slightly different purposes right now, the add-ons manager is aimed at the casual end user, they may need to enable/disable plugins but most of the other details they probably don't care much about.

> What's still not shown in the Add-ons manager:
> * plugin's supported MIME types – could be incorporated into its "More info"
> page.

I'd probably consider taking patches for this, though note that at the moment we can't get this information for disabled plugins.

> * plugin's file name – could also be incorporated into its "More info" page.

I'm not sure of the benefit of this for the casual end user

> * links to https://pfs.mozilla.org/plugins/ and http://plugindoc.mozdev.org/
> – could be moved into the top or bottom of Add-ons Manager's Plugins page –
> just like the link to http://www.mozilla.com/plugincheck/ is already there.

I don't want multiple links up there really.
I'm more inclined to say that most of the information could be moved from about:plugins to about:support
Either would be fine, and I guess it's mostly up to the UX team. My main point is that about:plugins seems needlessly separated into its own page IMO.
Whiteboard: uiwanted
(In reply to comment #1)
> (In reply to comment #0)
> > * plugin's supported MIME types – could be incorporated into its "More info"
> 
> I'd probably consider taking patches for this, though note that at the
> moment we can't get this information for disabled plugins.

Just caching the info somewhere would probably be enough.

(In reply to comment #2)
> I'm more inclined to say that most of the information could be moved from
> about:plugins to about:support

-> bug 638769
Bug 619652 has merged the information into the Add-ons Manager, bug 747301 would remove about:plugins.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 619652
You need to log in before you can comment on or make changes to this bug.