If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[PP] drag and drop file into message attachment pane does not show a feedback

VERIFIED WORKSFORME

Status

MailNews Core
Backend
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: pmock, Assigned: varada)

Tracking

Trunk
mozilla1.0
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Bug found while verifying bug http://bugzilla.mozilla.org/show_bug.cgi?id=39630

Build Date & Platform Bug Found: 
 macos commercial seamonkey build 2001-011904-mtrunk installed on G3/400 OS 9.04

Overview Description: 
 On Win32 and Linux, you can drag and drop attachments into the attachment pane.

Steps to Reproduce: 
1) Start a new mail message
2) Take a file (text or jpg) from the desktop and try to drag and drop into the 
attachment pane.  
   The file is not attached.  No warning or error message.

Actual Results: 
 Dragging the file over the attachment pane results in no change to the mouse 
arrow.  It does not allow you to drop the file in the pane.

Expected Results: 
 It should attach the file.

Additional Builds and Platforms Tested On: 
 You can drag and drop file on win32 and linux.
 win32 commercial seamonkey build 2001-010821-mtrunk installed on P500 Win98
 linux commercial seamonkey build 2001-011911-mtrunk installed on P200 RedHat 
6.2

Updated

17 years ago
QA Contact: esther → sheelar

Comment 1

17 years ago
reassing->fenella
QA Contact: sheelar → fenella

Comment 2

17 years ago
to esther..
QA Contact: fenella → esther

Comment 3

17 years ago
This bug might be a duplicate or "works for me." You can drag and drop attachments
in Mac Mozilla 0.8. Bug 69525 addresses the problem of the file not actually
being attached when using drag and drop.

Comment 4

16 years ago
Works for me using Mac/2001091311 (0.9.4), although while the file is being held
over the Attachments pane no visible indication is given that the file will be
accepted upon drop.
Whiteboard: wfm
Right, this is working now again but we are missing a feedback (hilite of the
attachment list). Updating summary and reassign to varada
Assignee: ducarroz → varada
Summary: [Feature][PP] can't drag and drop file into message attachment pane → [PP] drag and drop file into message attachment pane does not show a feedback
Whiteboard: wfm
Target Milestone: --- → mozilla1.0

Comment 6

16 years ago
I can successfully drag and drop a single file onto the attachment pane.

However, if I highlight multiple file icons and attempt to drag and drop them
all into the attachment pane, only one of the files gets attached.

Would that be this bug?  Originally this bug was about drag and drop not
functioning, but now it seems to just be about a lack of a cosmetic status
change display.

(I am using MacOS 9.2 and have not tested to see if it is possible to drag and
drop attach multiple files on Windows or Linux)

Comment 7

16 years ago
marking WFM based on comments.

Mike, multiple drag and drop is http://bugzilla.mozilla.org/show_bug.cgi?id=69528
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
wfm with build 2001-11-30, Mac OS X 10.1.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.