cannot subscribe to a news server with large number of groups

RESOLVED WORKSFORME

Status

MailNews Core
Networking: NNTP
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Pavel Vozenilek, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.17) Gecko/20110414 Thunderbird/3.1.10

I have ADSL connection with down speed about 1 Mbit/sec and freshly installed Thunderbird with default settings. 


news.gname.org keeps several thousands of newsgroups. When I try to populate the newsgroups list, to subscribe some of them, I always get "Connection to news.gname.org timed out". I can successfully connect to other news servers.

There's no obvious way to subscribe a newsgroup manually. I had the same problem with Gname and with older version of MS Outlook.



Reproducible: Always

Steps to Reproduce:
1. create news account for news.gname.org
2. try to subscribe newsgroups
3. wait 10-20 second till timeout

Actual Results:  
timeout error message and no newsgroups in the subscription window
(Reporter)

Comment 1

7 years ago
To be exact, right now Gname keeps 12697 new groups.
How does a traceroute to gmame looks like from your isp ?

Comment 3

6 years ago
Which program produces the timeout error? Can you attach a screenshot? Does it still happen in TB13?
Component: Account Manager → Networking: NNTP
Product: Thunderbird → MailNews Core
QA Contact: account-manager → networking.nntp
I've tested with news.gmane.org; while the server does seem to have a load issue, if I keep trying every once in a while, I can successfully download the newsgroup subscription. I've also tested the newsgroup subscription dialog on a server with >100K newsgroups (gmane's count is only in the ~30K range IIRC).

All things considered, the issue is dominated not by anything that TB can do (we do support manual newsgroup subscription via URLs) but rather by server load issues on gmane's end.

--> RESOLVED WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.