Allow using system environment variables in prefs.js

RESOLVED WONTFIX

Status

()

Core
Preferences: Backend
--
enhancement
RESOLVED WONTFIX
7 years ago
8 months ago

People

(Reporter: natanji, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20110601 Firefox/4.0.1
Build Identifier: All

It would be great to have a way to access arbitrary system environment variables in prefs.js. Right now, we can only access some specific Mozilla environment variables using %VARNAME%. This is a limitation because system environment variables would allow e.g. configuring paths inside prefs.js for different systems on which the same Firefox/Thunderbird profile is used, to e.g. be able to make different settings when using the same profile in Linux and Windows.

From what I saw, this was not requested before. There are also no extensions supporting this simple feature yet; there is Dropfox (https://addons.mozilla.org/de/firefox/addon/dropfox/) which introduced the notion of writing ${VARNAME} to access system-wide environment variables, but this extension doesn't work with FF4+ or Thunderbird and I believe a feature like this should rather be implemented directly in Mozilla.

Reproducible: Always
Although I can see this might be useful in some circumstances, the age and quietness of this bug report suggests that it would be a niche feature, and I don't think it is worth the additional complexity it would entail.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.