Last Comment Bug 663768 - Clean up syncloadservice
: Clean up syncloadservice
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Jonas Sicking (:sicking) No longer reading bugmail consistently
:
:
Mentors:
Depends on:
Blocks: 661297
  Show dependency treegraph
 
Reported: 2011-06-13 02:04 PDT by Jonas Sicking (:sicking) No longer reading bugmail consistently
Modified: 2011-06-19 00:00 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part 1: Don't use events to detect load-done (8.07 KB, patch)
2011-06-13 02:04 PDT, Jonas Sicking (:sicking) No longer reading bugmail consistently
jst: review+
Details | Diff | Splinter Review
Part 2: kill syncload XPCOM service (13.72 KB, patch)
2011-06-13 02:05 PDT, Jonas Sicking (:sicking) No longer reading bugmail consistently
no flags Details | Diff | Splinter Review
Part 2: Kill syncload XPCOM service (41.87 KB, patch)
2011-06-13 02:19 PDT, Jonas Sicking (:sicking) No longer reading bugmail consistently
no flags Details | Diff | Splinter Review
Part 2: Kill syncload XPCOM service (15.62 KB, patch)
2011-06-13 02:25 PDT, Jonas Sicking (:sicking) No longer reading bugmail consistently
jst: review+
Details | Diff | Splinter Review

Description Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-06-13 02:04:42 PDT
Created attachment 538829 [details] [diff] [review]
Part 1: Don't use events to detect load-done

The syncload service currently uses load/error events to figure out when it can stop spinning the event loop. It would be much simpler to simply stop spinning once OnStopRequest is called on the stream listener.

Additionally, the syncloadservice implements a scriptable XPCOM service which we don't seem to use anywhere in our code, so we should just nuke it.
Comment 1 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-06-13 02:05:44 PDT
Created attachment 538830 [details] [diff] [review]
Part 2: kill syncload XPCOM service
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-06-13 02:19:04 PDT
Created attachment 538833 [details] [diff] [review]
Part 2: Kill syncload XPCOM service

Nuked and inlined another function since it was only used in one place.
Comment 3 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-06-13 02:25:31 PDT
Created attachment 538837 [details] [diff] [review]
Part 2: Kill syncload XPCOM service

Erm.. that last patch was borked. This one's correct.
Comment 4 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-06-19 00:00:31 PDT
Checked in!

http://hg.mozilla.org/mozilla-central/rev/44c904e24e4d
http://hg.mozilla.org/mozilla-central/rev/0830b8ed9f02

Note You need to log in before you can comment on or make changes to this bug.