NoScript 2.1.1.2rc1 (meant for the beta channel) is being served in the stable channel

RESOLVED FIXED in 6.1.1

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
P2
major
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: mao, Assigned: jorgev)

Tracking

unspecified
6.1.1

Details

(Reporter)

Description

7 years ago
All NoScript's RCs (version number like 1.2.3.4rc5) have automatically gone in the beta channel on upload and stayed there, even if multiple times, when I uploaded a RC before the previous stable had been reviewed and published, the message I got from AMO upon review referred to the latest RC, rather than the stable version: the version published in the stable channel was always the stable (non RC) one, anyway.

Yesterday I received the usual notification saying that NoScript 2.1.1.2rc1 had passed full review, and I ignored it as always in the past, believing that the version actually published in the stable channel was 2.1.1.1 no matter the message, as usual.

Instead this morning I've found several mail from disoriented users who were asking (sometimes complaining) about being suddenly switched to the beta channel, because, in fact, they were receiving a RC as a stable update.

Does it actually mean that 1) all NoScript users are being mass-switched to the beta channel?
Or 2) is it just a glitch causing this specific version to be marked as stable (and they'll get the following stable update, rather than the beta one)?

Either way, the mere fact this could happen seems a bug to me (even though my #1 scenario configures a much more serious problem than #2). Beta version shouldn't be proposed for editor review, let alone be distributed in the stable channel. I just hope this doesn't also imply a mass-switch to the beta channel for the whole user base (hence the "major" severity, until this is cleared up).
(Assignee)

Updated

7 years ago
Assignee: nobody → jorge
Priority: -- → P2
Target Milestone: --- → 6.1.1
(Assignee)

Comment 1

7 years ago
See bug 663248 comment #2 for the cause of this problem. I fixed the status of both the beta file and the stable file, but you'll probably need to upload a new stable version if you want to move your current users out of the RC.

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> you'll probably need to
> upload a new stable version if you want to move your current users out of
> the RC.

Does it mean current beta testers would be dragged out from the beta channel as well, and should opt-in back later?
Priority: P2 → --
Target Milestone: 6.1.1 → ---
(Assignee)

Comment 3

7 years ago
Good question. I think AMO handles all of the channel stuff, so if you currently have a version that we recognize as beta, then you're on the beta channel, which would invalidate my recommendation on comment #1. Wil, can you confirm?
Priority: -- → P2
Target Milestone: --- → 6.1.1
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.