Old nightly build does not upgrade to latest build through about dialog

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: George Carstoiu, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 538862 [details]
Screenshot 2

Mozilla/5.0 (X11; Linux i686; rv:6.0a1) Gecko/20110521 Firefox/6.0a1

Trying to upgrade Nightly to latest trunk through the about dialog fails, informing the user that "Nightly is up to date", although it is not - see Screenshot 1 (taken on the 13th of June)

Reproducible: always

Steps to reproduce:
 1. Download and install an older Nightly build
 2. Start Nightly
 3. Go to Help-> About Nightly

Actual results:
 - the user is informed that the "Nightly is up to date"

Expected results:
 - the newer build starts to download and the user is given the opportunity to update its browser

Note:
 - reproduced issue on Ubuntu 11.04 x86, Win7 x86 and Mac OS X 10.6
 - while trying to reproduce issue got error from Screenshot 2 - not sure if it's related or not
(Reporter)

Comment 1

7 years ago
Created attachment 538865 [details]
Screenshot 1
WFM from Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:6.0a1) Gecko/20110513 Firefox/6.0a1 ID:20110513030218 offered update to latest nightly.
(Reporter)

Comment 3

7 years ago
 Mozilla/5.0 (X11; Linux i686; rv:6.0a2) Gecko/20110703 Firefox/6.0a2

It looks like it was a local thing. Closing issue as Resolved Invalid.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.