non-looped GIF animation doesn't restart on reload / open in new tab

RESOLVED DUPLICATE of bug 129986

Status

()

defect
RESOLVED DUPLICATE of bug 129986
8 years ago
8 years ago

People

(Reporter: andrew, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0 Iceweasel/5.0
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0 Iceweasel/5.0

Non-looped animated GIF files get stuck at the last frame even when I press F5/Reload. Shift-Reload reloads and restarts them, however. In my understanding, F5/Reload should reset the page to its original state thus restarting the animation, but it doesn't.

Reproducible: Always

Steps to Reproduce:
1. Open the non-looped GIF animation (URL to the sample is attached).
2. Wait for the animation to finish.
3. Hit Reload.

Actual Results:  
Nothing happens.

Expected Results:  
The animation is restarted from its very first frame.
(Reporter)

Updated

8 years ago
Component: Layout: Images → Document Navigation
Status: UNCONFIRMED → NEW
Component: Document Navigation → ImageLib
Ever confirmed: true
QA Contact: layout.images → imagelib
Is this a regression, by the way (that is, did this use to work correctly)?  If so, when did it appear?
Possibly related to bug 601723?
attachment 541231 [details] is a somewhat simpler testcase for this, btw.

> Is this a regression

Per bug 666422 comment 2, we've had our current behavior at least as far back as Firefox 3.5.
...though per bug 666422 comment 3, we're apparently the only browser with this behavior.
Summary: non-looped GIF animation doesn't restart on reload → non-looped GIF animation doesn't restart on reload / open in new tab

Comment 6

8 years ago
Duplicate of bug 129986?
Whiteboard: DUPEME? bug 129986
Yep, dupe of bug 129986.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
OS: Linux → All
Hardware: x86 → All
Resolution: --- → DUPLICATE
Whiteboard: DUPEME? bug 129986
Version: unspecified → Trunk
Duplicate of bug: 129986
You need to log in before you can comment on or make changes to this bug.