Mouseover URL in status bar overwritten by Document: Done after ~1 second

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: ml, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I suspect this is related to bug 49202 filed against MailNews.
It is very useful to see a link's URL by holding the pointer
over the link.  However, this feature is made nearly useless
as the link URL displayed in the statusbar is overwritten about
one second after the mouse has moved over the link by
"Document: Done (xxx secs)".  It would be nice if the link URL
statusbar display remained until the mouse has left the link.

Comment 1

18 years ago
I don't observe this behaviour on PC NT4 (build ID 2001011904). Once the URL is
displayed in the status bar it remains there until I move the mouse off the
link, at which point it is (correctly) replaced by the "Document: Done..." text.
(Reporter)

Comment 2

18 years ago
Maybe it is a Linux only bug.  I haven't tried a windows build in a few months,
but I remembered seeing the same behavior at that time, so I ASSumed it was
still present for all builds.  I changed the OS to 'Linux'.  Also tried again
with latest nightly build
(Mozilla/5.0 (X11; U; Linux 2.2.17 i686; en-US; m18) Gecko/20010124), behavior
still present.
OS: All → Linux

Comment 3

18 years ago
Marking NEW as per reporters comments. Reporter can you please attach a testcase
or a link to a page where this is occuring?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

18 years ago
Worksforme with 013108 mozilla build on RedHat6.2  The URL remains in the
statusbar as long as the pointer is over the link.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Component: Browser-General → XP Apps: GUI Features
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

18 years ago
Since entering this bug I have tried several nightly builds and releases (most
recently 0.8).  On my Debian 2.2/XFree 3.3.6 box, I've seen the problem with
every release.  On a RedHat 7/XFree 4 box, I've never seen the problem.  Maybe
this is a Debian or XFree 3 problem, or perhaps my home box is just screwed up.
 I've also noticed since that on the Debian box links that are supposed to
change on hover only change for a second, while on the RH box they stay changed
as long as the mouse is over the link.  If there's any more relevant information
I can provide, let me know.

Comment 6

15 years ago
The "Done" text appears in the status bar 100% of the time after I stop moving
the mouse over the URL. While the mouse is moving, I can see the link text. --
lpangelrob (6/7/04)
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.