〈 and ⟨ in different typefaces, as are 〉 and ⟩

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: jdawiseman, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

See following worked example, in which the named character entities ⟨ and ⟩ do not render in the same typeface as their numeric ‘equivalents’ 〈 and 〉.

But they should be the same: see 
http://www.w3.org/TR/WD-html40-970708/sgml/entities.html


Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 539012 [details]
Shows 〈 = 〈 ≠ ⟨, and 〉 = 〉 ≠ &#rang;.
(Reporter)

Comment 2

8 years ago
This bug might be (distantly) related to bug 652508.
(Reporter)

Comment 3

8 years ago
Created attachment 539015 [details]
Screen shot of attachment 539012 [details]

Updated

8 years ago
Attachment #539012 - Attachment mime type: text/plain → text/html

Updated

8 years ago
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: unspecified → 2.0 Branch
⟨ and ⟩ have been changed to U+27E8 and U+27E9. See bug 603716.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
For ⟨ and ⟩ we use:

27E8;MATHEMATICAL LEFT ANGLE BRACKET;Ps;0;ON;;;;;Y;;;;;
27E9;MATHEMATICAL RIGHT ANGLE BRACKET;Pe;0;ON;;;;;Y;;;;;

rather than HTML4's:

2329;LEFT-POINTING ANGLE BRACKET;Ps;0;ON;3008;;;;Y;BRA;;;;
232A;RIGHT-POINTING ANGLE BRACKET;Pe;0;ON;3009;;;;Y;KET;;;;

or HTML5's:

27EA;MATHEMATICAL LEFT DOUBLE ANGLE BRACKET;Ps;0;ON;;;;;Y;;;;;
27EB;MATHEMATICAL RIGHT DOUBLE ANGLE BRACKET;Pe;0;ON;;;;;Y;;;;;
Status: RESOLVED → UNCONFIRMED
Component: Layout: Text → HTML: Parser
OS: Mac OS X → All
QA Contact: layout.fonts-and-text → parser
Hardware: x86 → All
Resolution: INVALID → ---
Er, sorry, HTML5 does match what we do.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
FWIW, the Math WG manages the named character mappings. They had some reason to change the mappings. IIRC, this had something to do with the character classes. HTML5 uses the mappings from the Math WG.

Reporter, for future reference: When filing bugs, please read http://www.whatwg.org/specs/web-apps/current-work/multipage/ instead of any of the HTML 4.x specs.
(Reporter)

Comment 8

8 years ago
Apologies. I was not aware that these mappings could be altered. 

Nonetheless, the posted example HTML does start:
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN""http://www.w3.org/TR/html4/loose.dtd">

so my thinking that &#9001; = &#x2329; should match &lang; wasn’t utterly foolish. (Should HTML 4 be rendered as HTML 4 rather than as something else?)
(In reply to comment #8)
> (Should HTML 4 be rendered as HTML 4 rather than as something else?)

All text/html is treated as (potentially invalid) latest flavor of HTML that has been implemented. Browsers don't have separate implementations for different HTML versions.

Updated

7 years ago
Duplicate of this bug: 686729
You need to log in before you can comment on or make changes to this bug.