Last Comment Bug 664109 - Requests for changes to the TLD whitelist for IDN, to add .ee
: Requests for changes to the TLD whitelist for IDN, to add .ee
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Networking: Domain Lists (show other bugs)
: Trunk
: All All
: -- enhancement with 1 vote (vote)
: mozilla13
Assigned To: Georg Kahest
:
:
Mentors:
http://www.internet.ee
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-14 04:32 PDT by Georg Kahest
Modified: 2012-03-29 15:45 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Allow idn for .ee (498 bytes, patch)
2011-09-29 00:29 PDT, Georg Kahest
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Georg Kahest 2011-06-14 04:32:40 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.16) Gecko/20110429 Iceweasel/3.5.16 (like Firefox/3.5.16)
Build Identifier: Mozilla/5.0

.ee cctld has launched IDN, please whitelist our tld in your browser default config.

Registry homepage: http://internet.ee/
changes to rules: http://www.internet.ee/eng/domain-regulation/domain-regulation-amendments

list of allowed chars can be found from:
http://www.internet.ee/eng/domain-regulation/rules-regarding-the-reservation-of-domains-names-with-idns parapgraph 1.1

contact: Georg Kahest system administrator georg.kahest@eestiinternet.ee


Reproducible: Always
Comment 1 Georg Kahest 2011-09-29 00:29:37 PDT
Created attachment 563325 [details] [diff] [review]
Allow idn for .ee

Patch for adding .ee to IDN whitelist by default.
Comment 2 Jothan Frakes 2011-09-29 13:36:22 PDT
Please supply the following in support of this request:

1] Registry web page URL
2] Policy for IDN registrations URL 
3] Code Points / Set of allowed characters URL

-Jothan
Comment 3 Martin 2011-10-05 05:02:12 PDT
Hi,

1) Registry web page URL : http://www.internet.ee
2 & 3) Policy for IDN registrations URL and Code Points / Set of allowed characters URL : http://www.internet.ee/eng/domain-regulation/list-of-letters-allowed-in-ee-domains

---
Martin
Comment 4 Jothan Frakes 2011-11-21 18:47:26 PST
I have reviewed the registry policy and code pages.  There are no visually similar or problematic characters in the explicit IDN set of characters that have been submitted.

Quoting http://www.internet.ee/eng/domain-regulation/list-of-letters-allowed-in-ee-domains :

"
According to domain regulation sub-paragraph 3.2 , aside from "-" and numbers(0-9) only Estonian alphabet letters can be used in a .ee domain name.

Estonian alphabet includes the following letters:

a, b, c, d, e, f, g, h, i, j, k, l, m, n, o, p, q, r, s, š, z, ž, t, u, v, w, õ, ä, ö, ü, x, y
"
.
.
.
"
õ – latin small letter O with tilde (U+00F5)
ä – latin small letter A with diaeresis(U+00E4)
ö – latin small letter O with diaeresis (U+00F6)
ü – latin small letter U with diaeresis (U+00FC)
š – latin small letter S with caron (U+0161)
ž – latin small letter Z with caron' (U+017E)
"

I propose that this TLD has met the current requirements and moves forth to the list, can I get two approves from the community please?

-J
Comment 5 tomorrow 2012-01-20 23:45:37 PST
You have my vote on this. Hopefully there will be more.
Comment 6 Gervase Markham [:gerv] 2012-02-21 10:08:30 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/e97aa93578e9

Gerv
Comment 7 Ed Morley [:emorley] 2012-02-22 10:49:31 PST
https://hg.mozilla.org/mozilla-central/rev/e97aa93578e9
Comment 8 Gervase Markham [:gerv] 2012-02-27 05:03:07 PST
Comment on attachment 563325 [details] [diff] [review]
Allow idn for .ee

[Approval Request Comment]
User impact if declined: IDNs not working (displaying as gibberish) in relevant domain.
Testing completed (on m-c, etc.): Policy rather than code change; but patch has baked over the weekend.
Risk to taking this patch (and alternatives if risky): Very low.
String changes made by this patch: None.

Gerv
Comment 9 Alex Keybl [:akeybl] 2012-02-27 15:30:09 PST
Comment on attachment 563325 [details] [diff] [review]
Allow idn for .ee

[Triage Comment]
Assuming this has gone through all the proper processes, approving for Aurora 12 and Beta 11. We do not expect to see any regressions caused by this patch which, as Gerv notes, is really just policy change.
Comment 10 Justin Wood (:Callek) 2012-03-05 14:21:53 PST
http://hg.mozilla.org/releases/mozilla-beta/rev/b7f76a01c3c7
Comment 11 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-05 16:46:03 PST
Is there anything QA can do to verify this fix?

Note You need to log in before you can comment on or make changes to this bug.