Mozilla hangs accessing ASPs and ISAs over https

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
18 years ago
2 years ago

People

(Reporter: jsp, Assigned: javi)

Tracking

1.0 Branch
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.25 KB, text/plain
Details
(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.7) Gecko/20010109
BuildID:    2001010816

Mozilla 0.7 for the Macintosh hangs if data is posted to an ISAPI DLL or Active
Server Page (ASP) running on Microsoft Internet Information Server 5.0 over a
secure connection (https protocol).

Reproducible: Always
Steps to Reproduce:
I'll attach a test case. The attached file must be put on an IIS server and
named "mozmacsslbug.asp". Once it's there, type the URL into Mozilla
(https://...whatever.../mozmacsslbug.asp). Click the submit button, and the same
page will be regenerated. If Mozilla doesn't hang, click the button again.

Actual Results:  After a few repetitions (typically two), Mozilla hangs.

Expected Results:  Mozilla should draw the page and allow interaction with it.

The problem does not manifest with Mozilla for Windows, or if a comparable CGI
is used, or if the form method is GET instead of POST, or if the connection is
open rather than secure, or if there is no script element (with a src attribute
specified) in the head. (Whether the script file referred to exists or not makes
no difference; the problem occurs either way.) It also manifests if an
equivalent ISA is used in place of the testcase ASP. Given the complexity of the
conditions that must be met to reproduce the bug, I could only guess at which
component this properly belongs to.

Though the causes differ, the behavior here is similar to that reported in bug
60204.
(Reporter)

Comment 1

18 years ago
Created attachment 23366 [details]
Test case.
->Crypto for https issues
Assignee: mstoltz → ddrinan
Component: Security: General → Security: Crypto
QA Contact: ckritzer → junruh

Comment 3

18 years ago
Mozilla on a Mac using ISAPI and ASP on MS IIS using SSL. Can you say nightmare? 
qawanted keyword
Keywords: qawanted
(Reporter)

Comment 4

18 years ago
Sure, I can say "nightmare," but I prefer "well-qualified." ;-) (I have to
admit, though, that I *don't* know that it's IIS-specific. I haven't set up any
other SSL testbeds.)

What's the significance of "qawanted?" I'd be happy to test a fix, if that's
what it's about. (I can't build the browser on the Mac, however, so I'd need it
pre-built.)

Comment 5

18 years ago
Qawanted is we need someone else to confirm it. None of us really have access to
to confirm this bug, before we can even come up with a patch.

Comment 6

18 years ago
access to the resources needed before we can verify this bug that is.

Comment 7

18 years ago
Is this related to bug 62810?
Assignee: ddrinan → javi
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

18 years ago
I don't know enough to say that this is unrelated, but if bug 62810 is indeed
related to integration with MRJ, the connection to this bug is not obvious to
me. I don't know if it's a useful diagnostic, but the problem occurs whether or
not Java support is enabled in Mozilla's preferences. (Using M 0.8.)
(Reporter)

Comment 9

18 years ago
Ran 50 iterations of the test case with 2001033004 without failure.  Since I
seem to be the only one who can test this, perhaps it should be marked fixed.
(I'd be happier if someone else could verify both that it was broken and that it
is now fixed.)

Comment 10

18 years ago
Marking worksforme. Reopen if the problem appears again.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 11

18 years ago
Verified.
Status: RESOLVED → VERIFIED

Updated

18 years ago
Keywords: qawanted

Comment 12

18 years ago
Mass changing Security:Crypto to PSM
Component: Security: Crypto → Client Library
Product: Browser → PSM
Version: other → 2.1

Comment 13

18 years ago
Mass changing Security:Crypto to PSM

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

11 years ago
Version: psm2.1 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.