Last Comment Bug 664324 - [session restore cleanup] Remove trailing whitespace
: [session restore cleanup] Remove trailing whitespace
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: Firefox 15
Assigned To: Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
:
Mentors:
: 724125 (view as bug list)
Depends on: 745040
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-14 16:14 PDT by Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
Modified: 2013-01-16 05:20 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
nsSessionStartup.js (5.47 KB, patch)
2011-07-29 14:53 PDT, Alastair Robertson
no flags Details | Diff | Review
nsSessionStore.js (46.50 KB, patch)
2011-07-29 14:55 PDT, Alastair Robertson
no flags Details | Diff | Review
remove trailing white spaces from nsSessionStartup.js (3.87 KB, patch)
2012-05-25 03:59 PDT, Tim Taubert [:ttaubert]
no flags Details | Diff | Review
removing trailing whitespace from all sessionstore files (82.49 KB, patch)
2012-05-25 14:29 PDT, Tim Taubert [:ttaubert]
paul: review+
Details | Diff | Review

Description Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-06-14 16:14:13 PDT
There's a lot of trailing whitespace and it bothers me. Instead of maybe fixing it piecemeal if a test or surrounding code gets touched, I'd rather just do it all in one go and be more vigilant for new code.
Comment 1 Alastair Robertson 2011-07-29 14:53:04 PDT
Created attachment 549482 [details] [diff] [review]
nsSessionStartup.js
Comment 2 Alastair Robertson 2011-07-29 14:55:23 PDT
Created attachment 549483 [details] [diff] [review]
nsSessionStore.js

Assuming these patches are ok, I can do the same to the other files in browser/components/sessionstore as well.

Should all the tests have trailing spaces removed too?
Comment 3 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-07-29 16:09:45 PDT
I've actually had these and others in my patch queue since I filed this. But the problem I've had is that there's no great time to land this - it's going to be super annoying to people working on larger sessionstore bugs right now (I know bug 516755 which is a big project and bug 587873 which is less bad). This is also going to bitrot fast. I think we should hold off until we have a nice quiet sessionstore period.

I should have made it clear here that this is stalled for the time being, so I apologize that you spent the time doing these. Hopefully you didn't spend too long!

I can see you're itching for some more bugs to work on, so I'll try to find one that's more ready.
Comment 4 Alastair Robertson 2011-07-29 16:11:16 PDT
Ah that's ok - it didn't take very long to do those
Comment 5 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-02-03 15:11:03 PST
*** Bug 724125 has been marked as a duplicate of this bug. ***
Comment 6 Tim Taubert [:ttaubert] 2012-05-25 03:59:09 PDT
Created attachment 627168 [details] [diff] [review]
remove trailing white spaces from nsSessionStartup.js
Comment 7 Tim Taubert [:ttaubert] 2012-05-25 14:29:04 PDT
Created attachment 627365 [details] [diff] [review]
removing trailing whitespace from all sessionstore files
Comment 8 Tim Taubert [:ttaubert] 2012-05-25 14:41:11 PDT
https://hg.mozilla.org/integration/fx-team/rev/ad13022897ba
Comment 9 Rob Campbell [:rc] (:robcee) 2012-05-26 10:32:21 PDT
https://hg.mozilla.org/mozilla-central/rev/ad13022897ba

Note You need to log in before you can comment on or make changes to this bug.