Last Comment Bug 664376 - table rows of XUL trees no longer containing cell content as accessible name
: table rows of XUL trees no longer containing cell content as accessible name
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: alexander :surkov
:
: alexander :surkov
Mentors:
Depends on:
Blocks: namea11y 546812
  Show dependency treegraph
 
Reported: 2011-06-15 01:17 PDT by Marco Zehe (:MarcoZ)
Modified: 2011-06-30 10:46 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (6.51 KB, patch)
2011-06-28 23:03 PDT, alexander :surkov
mzehe: review+
Details | Diff | Splinter Review

Description Marco Zehe (:MarcoZ) 2011-06-15 01:17:54 PDT
STR:
1. Open about:config.
2. Inspect the table.

Expected: The row accessibles should contain an accessible name consisting of all the string values of the cells below them.
Actual: They're empty now.

This is a regression from bug 546812, which was supposed to only fix the accessible name propagation from the tree container to the individual rows, but should not have broken name calculation from the cells up to the row.
Comment 1 Marco Zehe (:MarcoZ) 2011-06-15 01:19:30 PDT
A direct result is that, when arrowing up and down through the table, NVDA no longer reads the currently selected item.
Comment 2 alexander :surkov 2011-06-15 04:07:38 PDT
changing summary to better reflect the bug (otherwise it sounds like tree tables are affected too)
Comment 3 alexander :surkov 2011-06-15 04:09:32 PDT
though actually we want to have rows of tables and tree tables for XUL trees to expose name as cell name concatenation (Marco filed bug 664384 to deprecate this approach in the future).
Comment 4 Trevor Saunders (:tbsaunde) 2011-06-28 19:00:13 PDT
Surkov, where you planing on working on this soon?  I think this probably causes a bit of pain in nvda, or atleast will when it gets to something other than nightly, and I noticed that I couldn't check that the fix for bug 659018  actually worked because orca nolonger reads anything in the message view in thunderbird.
Comment 5 alexander :surkov 2011-06-28 23:03:03 PDT
Created attachment 542729 [details] [diff] [review]
patch
Comment 6 Marco Zehe (:MarcoZ) 2011-06-29 05:22:32 PDT
Comment on attachment 542729 [details] [diff] [review]
patch

r=me, thanks!
Comment 7 Trevor Saunders (:tbsaunde) 2011-06-29 17:26:20 PDT
pushed to try with 666504 606085  666337  429642   667396 as http://tbpl.mozilla.org/?tree=Try&rev=dbf9bbf7adc9
Comment 8 Trevor Saunders (:tbsaunde) 2011-06-30 10:33:10 PDT
landed http://hg.mozilla.org/mozilla-central/rev/3b60b16fce55

Note You need to log in before you can comment on or make changes to this bug.