Can't upload attachments: files[f].fileName is undefined

VERIFIED FIXED in Builder 0.9.7

Status

addons.mozilla.org Graveyard
Add-on Builder
VERIFIED FIXED
7 years ago
4 years ago

People

(Reporter: clouserw, Assigned: seanmonstar)

Tracking

unspecified
Builder 0.9.7

Details

(Reporter)

Description

7 years ago
To reproduce:

1) https://builder-addons.allizom.org/addon/1000134/latest/
2) Click [+] next to Data
3) Pick a file and click upload

See this in error console:
Error: files[f].fileName is undefined
Source File: https://builder-addons.allizom.org/media/jetpack/js/Sidebar.js
Line: 541


I'm using a nightly
(Reporter)

Comment 1

7 years ago
This works in fx 4.0.1
(Reporter)

Updated

7 years ago
Target Milestone: Builder 0.9.6 → Builder 0.9.7
(Reporter)

Updated

7 years ago
Duplicate of this bug: 665026
(Assignee)

Comment 3

7 years ago
This still happening in the nightlies?

Even if so, this is a browser bug...
(Reporter)

Comment 4

7 years ago
I think we concluded the browser API changed
(Assignee)

Comment 5

7 years ago
If this is the case, I'll need a link to the new API.

https://developer.mozilla.org/en/DOM/FileList currently says:

// loop trough files
for (var i = 0; i < files.length; i++) {

    // get item
    file = files.item(i);
    //or
    file = files[i];

    alert(file.name);
}
Assignee: nobody → smcarthur
(Assignee)

Comment 6

7 years ago
ok, this has been changed in master.

apparently, Fx7 is dropping support for it's non-standard .fileName property of files. We now access the standard .name property.

https://github.com/mozilla/FlightDeck/commit/e7d142777e99317961e7ed69777585bde9edfecc
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified FIXED using both Firefox 5, and nightlies on Windows/Mac.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.