Calling the "Setup Sync" action ("Extras.Sync einrichten…" in German) should not reset Sync config initially

RESOLVED INVALID

Status

Cloud Services
Firefox Sync: UI
--
enhancement
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Daniel Hahler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

I used to call ":emenu Extras.Sync einrichten…" in Pentadactyl to setup Sync on a new Firefox install.

I have now noticed that calling this will reset any existing config (which is available in "Preferences / Sync").

It might be better if the setup wizard ("Setup sync…") would not wipe any existing config, but either keep the existing data, unless the wizard is completed, or opens the existing config in the preference dialog's Sync tab instead.

Reproducible: Always

Steps to Reproduce:
1. Setup Sync via the "Extras / Setup sync…" menu entry (":emenu Extras.Sync einrichten…")
2. Call the menu action again and cancel it on the first screen

Actual Results:  
The previously entered information is lost.

Expected Results:  
The previously information/config should be kept, at least when calling "Cancel" on the first screen.
I would like it even better if the existing configuration would get displayed if it had been setup before.
Component: General → Firefox Sync: Backend
Product: Firefox → Mozilla Services
QA Contact: general → sync-backend
Yes, the wizard resets all Sync preferences when it's cancelled. Why are you opening the wizard when you already have Sync set up? This isn't supported as it's not possible through the normal UI.
Component: Firefox Sync: Backend → Firefox Sync: UI
QA Contact: sync-backend → sync-ui
(Reporter)

Comment 2

7 years ago
> Why are you opening the wizard when you already have Sync set up?

It is just an habit of ":emenu sync<tab>" and picking the wrong choice (besides "Sync now").

> This isn't supported as it's not possible through the normal UI.

I see. Looks like the menu gets removed dynamically by Sync?!
Or is there another reason for Pentadactyl picking it up (for the "sync" completion).
I am just wondering if this could get improved in/for Pentadactyl, so that is does not show up there, if it won't show up in the normal menu (which ":emenu" should reflect).
(In reply to comment #2)
> > This isn't supported as it's not possible through the normal UI.
> 
> I see. Looks like the menu gets removed dynamically by Sync?!

Yes, one of the "Setup sync" and "Sync" menu items are always hidden, depending on whether you have sync set up or not.

> I am just wondering if this could get improved in/for Pentadactyl, so that
> is does not show up there, if it won't show up in the normal menu (which
> ":emenu" should reflect).

Yes, I agree. Pentadactyl should behave a bit more sensibly here and not offer you hidden menu items. Resolving this as invalid since there's no bug in Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.