Firefox hangs (not crashes) on the plugin rich websites !

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Nilay Chheda, Unassigned)

Tracking

({hang})

6 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Stack attached)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

I am not sure about the reason behind the firefox hang. I will be just reporting what is happening with my browser.

- I was trying to connect to facebook.com
- Browser suddenly becomes not responding and each and every tabs or windows which are working also stuck.
- Since this problem is occurring for last one month, I have observed that when I wait from 1-3 minutes firefox resumes back and works well until next restart of the browser. But again the same problem occurs which is really frustrating.
- My browser always work in private browsing mode.
- Same thing happens with some other websites as well but this bug report was generated when I was visiting facebook.com
- There is one bug which was generated just before this one which says that ad block plus + java makes some problem together. In that case also problem was same but website(s) were different. I think that problem is temporarily solved because someone on IRC told me to disable some option in java control panel.


I am sorry for such a long description but I don't know how to explain this is brief. I have no idea which component is affected by this bug so I have selected "General".

Reproducible: Always




Computer Configuration
----------------------
Dell Vostro 1088 N series
windows 7 ultimate
Core 2 duo processor
ATI mobility readon HD 4330 graphic card
Group: core-security
Keywords: hang
This doesn't make sense
>Firefox hangs (not crashes) on the plugin rich websites 
and
>- I was trying to connect to facebook.com
connect = nothing loaded = what have this to do with plugins ?

Please attach a stacktrace using the "add an attachment" link above:
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg

You should also try it without addons -> http://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 2

7 years ago
I don't know why this doesn't make sense to you sir.

> Firefox hangs (not crashes) on the plugin rich websites 

According to me whenever firefox try to use 3rd party plugins it is not able to handle it properly.
I can't just disable standard plugins like flash, silverlight, shockwave etc.

By connection I mean I typed URL in the URL bar. Then I press enter and firefox hangs !
I have a screen shot of this which I am attaching and will try to attach stacktrace as soon as possible.
(Reporter)

Comment 3

7 years ago
Created attachment 540033 [details]
Screenshot of the hanging screen !

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 4

7 years ago
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile

What specific site(s) cause this issue?
(Reporter)

Comment 5

7 years ago
(In reply to comment #4)
> Does the issue still occur if you start Firefox in Safe Mode?
> http://support.mozilla.com/en-US/kb/Safe+Mode
> 
> How about with a new, empty profile?
> http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
> 
> What specific site(s) cause this issue?

- "Yes" this issue still occur in the safe mode of firefox !!! 

- As far as trying a new emplty profile is concerned I have already done that    more than two times.

- Well, specific sites on which this happens (for me at least)are as following

1. http://facebook.com/
2. http://youtube.com/
3. http://microsoft.com/
4. https://addons.mozilla.org/en-US/firefox/
5. http://subscene.com/

- These sites are just some of them. I can't really remember all the sites on 
which firefox hangs but it does hang a lot.

- One more thing I would like to share that I have configured my firefox to run always in the private browsing mode. This might help .

- And one last thing sometimes when firefox hangs I have noticed that there are lot of (around 10-12) plugin container for firefox processes are created in my task manager !!!
(Reporter)

Comment 6

7 years ago
Created attachment 540417 [details]
Another screen shot of firefox hang screen

- This screenshot shows the look of my task manager during firefox hang.
- In support of my previous comment I would like to add that when firefox hangs suddenly many plugin container processes are created and keep running until the firefox closes even if all the websites are closed and just http://google.com is running is single tab.
(Reporter)

Comment 7

7 years ago
(In reply to comment #1)
> This doesn't make sense
> >Firefox hangs (not crashes) on the plugin rich websites 
> and
> >- I was trying to connect to facebook.com
> connect = nothing loaded = what have this to do with plugins ?
> 
> Please attach a stacktrace using the "add an attachment" link above:
> https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
> 
> You should also try it without addons ->
> http://support.mozilla.com/en-US/kb/Safe+Mode

I am attaching the stack trace of firefox hang created by WinDbg according to instructions given in the above link . I hope this will be helpful !
(Reporter)

Comment 8

7 years ago
Created attachment 540429 [details]
Firefox Hang Stack trace using Windbg !

Updated

7 years ago
Whiteboard: Stack attached
Nilay, do you know if the Issues happens for you running on Firefox 6, too?
If not, can you test it please?
(Reporter)

Comment 10

7 years ago
(In reply to XtC4UaLL [:xtc4uall] from comment #9)
> Nilay, do you know if the Issues happens for you running on Firefox 6, too?
> If not, can you test it please?

I am using firefox 6 and I am glad to say that frequency of problem has decreased to fairly low amount.

But I must admit that sometimes firefox hangs("fortunately" never crashes) but overall I am very happy with firefox 6.

I also found somewhere over the internet that my problem might be because of divx player web plugin. Right now I have removed divx player which may have helped.
So it's probably Plugin Usage dependent, yes?
Can you pinpoint it even more by let's say running with all Plugins but e.g. Flash disabled for x Days and see if the Issues happen again?

Btw, I personally can confirm that the Divx Web Player's Plugin makes Firefox slow on Start-Up and change RAM-Usage and Responsiveness. Thus I dropped it.
Version: 4.0 Branch → 6 Branch

Comment 12

7 years ago
(In reply to Nilay Chheda from comment #10)
> (In reply to XtC4UaLL [:xtc4uall] from comment #9)
> > Nilay, do you know if the Issues happens for you running on Firefox 6, too?
> > If not, can you test it please?
> 
> I am using firefox 6 and I am glad to say that frequency of problem has
> decreased to fairly low amount.

FF 6.0.2 should provide you with relief over FF 4.

> But I must admit that sometimes firefox hangs("fortunately" never crashes)
> but overall I am very happy with firefox 6.
> 
> I also found somewhere over the internet that my problem might be because of
> divx player web plugin. Right now I have removed divx player which may have
> helped.

It is possible to use DivX but it installs more than just ONE Plugin. 

You need to remove: "DivX Plus Web Player HTML5 <video> 2.1.2.126" (or whichever version you have). It serves no purpose as FF supports HTML5, check here: http://www.youtube.com/html5 .

Now you can use the DivX Plugin (the other one; which I don't have installed so I can not quote it's name for you) to visit YouTube and the Flash Videos will have a "DivX Button" underneath them; click it to play the Flash Videos in DivX (with Hardware Acceleration and lower CPU usage than Adobe's Flash Player).

BUT, if you check the "fine print" on the DivX Site their YouTube Flash Player replacement Plugin is (was) in Beta and may crash. It is fun to try new things but it may increase the likelihood of crashes.


We should Blacklist "DivX Plus Web Player HTML5 <video> x.x.x.xxx" since it is installed for Firefox but serves no purpose (that I know of); it might be useful for the Mobile Browser (and old versions of FF).

Comment 13

7 years ago
The (mostly working) Beta DivX Plugin for YouTube (and a few other Sites) is called: "DivX Web Player 2.1.2.126", just be sure to disable "DivX Plus Web Player HTML5 <video> 2.1.2.126".
(Reporter)

Comment 14

7 years ago
Thanks friends, 

I think this bug has been resolved. I don't have any such problem with firefox 7.0.1

Happy Firefoxing :) :) :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.