socorro should use PEP8 for Python code

RESOLVED DUPLICATE of bug 1377254

Status

Socorro
General
RESOLVED DUPLICATE of bug 1377254
7 years ago
9 months ago

People

(Reporter: rhelmer, Assigned: willkg)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Quoting lars from bug 654567 comment 18:

"It is ironic that I be the one to say this, but we ought to adopt PEP8 coding standards for all new code in the project.  I know someone is going to quote me and I'll never hear the end of it..."

Comment 1

7 years ago
It would be good to discuss updating our style guide at the offsite next week. 

PEP8 is nice because of we could hook the compliance tools into our tests to enforce style.

Comment 2

7 years ago
Consensus at the offsite seemed to be that this was a fine way to go. I've updated the code conventions guide to indicate that PEP 8 with 4 space indents is how we will proceed.

Updated

7 years ago
Blocks: 669464
Depends on: 678408
Depends on: 679123

Updated

7 years ago
Depends on: 686547
Component: Socorro → General
Product: Webtools → Socorro

Updated

9 months ago
Assignee: nobody → willkg
Mmm... this is great, but I think bug #1377254 has a better mission and is a superset of this bug: fix things so we can lint in CI.

Given that, I think I'm going to close dupe this bug to that bug.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1377254
You need to log in before you can comment on or make changes to this bug.