alarm disappears after sync

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: doncorleone, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: 0.7.1

after creating a new event the alarm disappears after sync to google calendar

Reproducible: Always

Steps to Reproduce:
1. create new event with popup-alarm
2. save event
3.

Actual Results:  
event has no alarm at all

Expected Results:  
alarm should be synced

Log:

Adding item Neuer Termin2
Logging object...
action: Setting Upload Data:
content: application/atom+xml; charset=UTF-8
data: <entry xmlns:gd="http://schemas.google.com/g/2005" xmlns:gCal="http://schemas.google.com/gCal/2005" xmlns="http://www.w3.org/2005/Atom">
  <category scheme="http://schemas.google.com/g/2005#kind" term="http://schemas.google.com/g/2005#event"/>
  <title type="text">Neuer Termin2</title>
  <content type="text"/>
  <author>
    <name>null</name>
    <email>xxx@googlemail.com</email>
  </author>
  <gd:transparency value="http://schemas.google.com/g/2005#event.opaque"/>
  <gd:eventStatus value="http://schemas.google.com/g/2005#event.confirmed"/>
  <gd:where valueString=""/>
  <gCal:sendEventNotifications value="true"/>
  <gd:when startTime="2011-06-17T08:00:00+02:00" endTime="2011-06-17T09:00:00+02:00">
    <gd:reminder minutes="15" method="alert"/>
  </gd:when>
  <gd:visibility value="http://schemas.google.com/g/2005#event.default"/>
  <gCal:sequence value="0"/>
  <gCal:uid value=""/>
</entry>
End object
calGoogleRequest: Requesting POST http://www.google.com/calendar/feeds/xxx%40googlemail.com/private/full?ctz=Europe%2FBerlin
Logging calIEvent:
	id:unellg23df7ne4ql0i9alnee18
	editurl:http://www.google.com/calendar/feeds/xxx%40googlemail.com/private/full/unellg23df7ne4ql0i9alnee18/63443929836
	created:2011/06/16 19:50:36 Europe/Berlin isDate=0
	updated:2011/06/16 19:50:36 Europe/Berlin isDate=0
	title:Neuer Termin2
	content:null
	transparency:OPAQUE
	status:CONFIRMED
	startTime:2011/06/17 08:00:00 Europe/Berlin isDate=0
	endTime:2011/06/17 09:00:00 Europe/Berlin isDate=0
	location:null
	privacy:DEFAULT
	alarmLastAck:null
	snoozeTime:null
	isOccurrence: false
	Organizer: 
		ID: mailto:xxx@gmail.com
			Name: xxx@gmail.com
			Rsvp: FALSE
			Is Organizer: yes
			Role: null
			Status: null
	Attendees: 
	recurrence: no
	alarms: no
Duplicate of this bug: 678958
Confirmed per duplicate(s). I haven't been able to reproduce this, but it seems to happen.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

7 years ago
I had this problem originally, but found that setting the default alarm on Google Calendar to pop-up rather than e-mail corrected it.
Jim, thanks for the note! Don, can you confirm this fixes the bug? (or anyone else viewing this bug, for that matter)

Comment 5

7 years ago
It doesn't fix the bug.

Just to be clear: it is Lightning that isn't saving the category + reminders, not Google.
pinkpiglets, what is your default alarm setting in the Google Calendar Webinterface?
Duplicate of this bug: 678958

Comment 8

7 years ago
OK, so I have confirmed that the bug I originally logged is a duplicate of this bug. I have tried setting the default alarm on Google Calendar to pop-up but 'categories' and 'reminders' are still not being saved in Lightning.

Does anyone have any other ideas please?

Comment 9

7 years ago
Default setting is Pop-up 1 Hour

Comment 10

7 years ago
Any more ideas anyone?

Comment 11

4 years ago
I'm admin of a Google Apps domain, and we're using MT + Lightning.
And we have such problem (existing reminders not displaying, and edited ones not saving).

All works fine via web UI.

First case, which is 100% reproducible, appears when a user is renamed (login changed), and renaming back restores reminders display & edit-ability. Since this discovery, I don't rename users, I create another user with new name, and then migrate all data.

Still, that does not always help, because of
Second case. About 10% of new accounts have such problem. And I have't found a way to work it around well, that users have to use Google Calendar in a tab (there is MT addon for that) for reminders to appear, and local calendar for offline reminders.


Tell me if I can be any helpful, including giving credentials of accounts with such failure (not accounts of real users ofc, these accounts will be newly created specifically for testing, and I'll make sure problem is reproducible)
There has been a major rewrite of the Provider for Google Calendar between version 0.32 and 1.0. A vast number of bugs have been fixed during this rewrite, therefore I am closing lots of old bugs that I think might either be fixed or no longer apply to the latest version.

Please read the updated FAQ [1] for details on known issues. If you can reproduce your issue with the latest version of the Provider for Google Calendar and you can't find an existing bug that handles your case, please reopen this issue.

Thank you for your understanding.

[1] https://wiki.mozilla.org/Calendar:GDATA_Provider
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.