Last Comment Bug 664780 - All uploads to Box Net fail
: All uploads to Box Net fail
Status: VERIFIED FIXED
: regression
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal
: ---
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
:
Mentors:
http://www.box.net
Depends on:
Blocks: 661876
  Show dependency treegraph
 
Reported: 2011-06-16 11:13 PDT by David
Modified: 2015-04-19 23:39 PDT (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description David 2011-06-16 11:13:50 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110616 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110616 Firefox/7.0a1

Attempting to upload a file fails and appears to freeze. The 'cancel upload' also fails and it requires a site log out to halt. This worked with 3.6.x, works with 4.0.1, 5.0x, and any 6.0x that I can find. And it used to work approximately one week or so previously with 7.0a1.

Reproducible: Always

Steps to Reproduce:
1.Load site in FF and login
2.Open a folder to receive the file and select a local file to upload 
3.

Actual Results:  
Upload appears to start but does not progress and never completes.

Expected Results:  
Upload should should complete and the site displays a 'file uploaded successfully screen.

This problem is found with both the x86 bit and the x86_64 FF 7.0a1. Uploads work with both the x86 and x86_64 Internet Explorer 9. 

This site offers a limited but free service (which could be used to test this) as well as a commercial and paid service.
Comment 1 (mostly gone) XtC4UaLL [:xtc4uall] 2011-06-17 10:23:03 PDT
Confirmed against Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110617 Firefox/7.0a1 ID:20110617030741

WFM against Mozilla/5.0 (Windows NT 5.1; rv:6.0a2) Gecko/20110617 Firefox/6.0a2 ID:20110617042008

Might help out finding a Range?
http://harthur.github.com/mozregression/
Comment 2 David 2011-06-17 12:43:37 PDT
New things to me.

I ran the program as per your instructions as per your link and the links on it. It said that it sent a report.

I have a screen capture of the report number.

What now?
Comment 3 (mostly gone) XtC4UaLL [:xtc4uall] 2011-06-17 14:47:31 PDT
Nevermind, apparently it crashed and also me is having Problems running mozregression.

But you can do it by manually by checking the "mozilla-central" Directories (those containing the Win32 Builds) on http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/ for finding the last working and the first failing one.

Post the "Built from" URLs of both Builds you can get from "about:buildconfig".
Comment 4 David 2011-06-17 15:30:18 PDT
Hmm.. 

Non Geek alert Beep Beep.  :-)

Trying to help here. It says...

Last good nightly:  2011-06-05

First bad nightly:  2011-06-06


Else:

"build from" (fails) http://hg.mozilla.org/mozilla-central/rev/306bdc7101c3

"build from" (works)    whatever 2011-06-05   was? 

I don't have that build. I don't 'build' from code. I download and install and try 'your' builds.

How do I get that information for you?
Comment 5 (mostly gone) XtC4UaLL [:xtc4uall] 2011-06-17 22:32:18 PDT
Got it myself. Regression Range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4f9bbea16f75&tochange=caf81a228fff

+ Error Console Output:
Error: file_name is undefined
Source File: http://e1.boxcdn.net/resources/z7lqbr274h/js/section_application.js
Line: 1271
Comment 6 Boris Zbarsky [:bz] (still a bit busy) 2011-06-17 23:04:08 PDT
What other scripts does that page load?

But in any case, looks like fallout from them relying on the old and nonstandard file api stuff Kyle removed....

Kyle, is this just an evangelism issue?  If so, can you contact them, please?
Comment 7 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-06-18 07:04:58 PDT
Seems plausible.  I'll dig in on Sunday.
Comment 8 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-06-19 07:11:48 PDT
Yes, this is tech evang.  They're using File.fileName and File.fileSize.
Comment 9 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-06-20 12:56:16 PDT
Contact attempted.
Comment 10 David 2011-06-21 18:30:04 PDT
Was this "old and nonstandard file api stuff" also removed from FF 6.0 too? I ask because my bank site will no longer let me log in. I can login with the just released FF 5.0 but not with today's FF 6.0 Aurora nor with today's 7.0 Nightly.

My bank site is Suntrust and no I am not going to provide the password.  :-)  

https://www.suntrust.com/
Comment 11 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-06-21 18:31:49 PDT
No, it was not.  Please file a separate bug and CC me.
Comment 12 Chris Lawson (gone) 2011-06-21 21:02:02 PDT
(In reply to comment #10)
> my bank site will no longer let me log in. I can login with
> the just released FF 5.0 but not with today's FF 6.0 Aurora nor with today's
> 7.0 Nightly.
> 
> My bank site is Suntrust and no I am not going to provide the password.

If it also fails while spoofing your UA string as Fx 5 (while using 6.0 or 7.0), then definitely file a new TE bug...and cc me as well :)
Comment 13 David 2011-06-21 21:37:01 PDT
(In reply to comment #12)
> (In reply to comment #10)
> > my bank site will no longer let me log in. I can login with
> > the just released FF 5.0 but not with today's FF 6.0 Aurora nor with today's
> > 7.0 Nightly.
> > 
> > My bank site is Suntrust and no I am not going to provide the password.
> 
> If it also fails while spoofing your UA string as Fx 5 (while using 6.0 or
> 7.0), then definitely file a new TE bug...and cc me as well :)

Sure. But how do I do that? Go easy now. Non Geek here.  :-)
Comment 14 Chris Lawson (gone) 2011-06-21 21:42:38 PDT
The usual way is with something like this:

https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher/

cl
Comment 15 David 2011-06-22 07:49:20 PDT
(In reply to comment #9)
> Contact attempted.

You contacted,attempted to contact, Box Net about this? This problem is with their website page? Why is that? It worked before now with Fx 4 and it still works Fx 5 and Fx 6 so this code was removed in Fx 7 only then? I wonder how many other 'defective sites' this code change will find when Fx 7 is the official release?
Comment 16 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-06-22 07:58:25 PDT
(In reply to comment #15)
> (In reply to comment #9)
> > Contact attempted.
> 
> You contacted,attempted to contact, Box Net about this?

Yes.

> This problem is with their website page?

Yes.

> Why is that?

They are using non-standard things that have been removed.

> It worked before now with Fx 4 and it still works Fx 5 and Fx 6 so this code was removed in Fx 7 only then?

Yes.

> I wonder how many other 'defective sites' this code change will find when Fx 7 is the official release?

So far this is only the second site reported to have broken.  If we broke too much of the web we'll put the non-standard things back, but I don't think that's going to be the case here.
Comment 17 David 2011-06-22 08:11:04 PDT
(In reply to comment #16)
> (In reply to comment #15)
> > (In reply to comment #9)
> > > Contact attempted.
> > 
> > You contacted,attempted to contact, Box Net about this?
> 
> Yes.
> 
> > This problem is with their website page?
> 
> Yes.
> 
> > Why is that?
> 
> They are using non-standard things that have been removed.
> 
> > It worked before now with Fx 4 and it still works Fx 5 and Fx 6 so this code was removed in Fx 7 only then?
> 
> Yes.
> 
> > I wonder how many other 'defective sites' this code change will find when Fx 7 is the official release?
> 
> So far this is only the second site reported to have broken.  If we broke
> too much of the web we'll put the non-standard things back, but I don't
> think that's going to be the case here.


I see. May I ask what the other site is? I ask because I also have reported that my banking site no longer works with Fx 7. 

https://bugzilla.mozilla.org/show_bug.cgi?id=666095
Comment 18 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-06-22 08:20:03 PDT
(In reply to comment #17)
> (In reply to comment #16)
> > (In reply to comment #15)
> > > (In reply to comment #9)
> > > > Contact attempted.
> > > 
> > > You contacted,attempted to contact, Box Net about this?
> > 
> > Yes.
> > 
> > > This problem is with their website page?
> > 
> > Yes.
> > 
> > > Why is that?
> > 
> > They are using non-standard things that have been removed.
> > 
> > > It worked before now with Fx 4 and it still works Fx 5 and Fx 6 so this code was removed in Fx 7 only then?
> > 
> > Yes.
> > 
> > > I wonder how many other 'defective sites' this code change will find when Fx 7 is the official release?
> > 
> > So far this is only the second site reported to have broken.  If we broke
> > too much of the web we'll put the non-standard things back, but I don't
> > think that's going to be the case here.
> 
> 
> I see. May I ask what the other site is? I ask because I also have reported
> that my banking site no longer works with Fx 7. 
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=666095

The other site is Gmail (Bug 662838).  Google is deploying a fix there.
Comment 19 David 2011-06-22 14:00:35 PDT
(In reply to comment #18)
> (In reply to comment #17)
> > (In reply to comment #16)
> > > (In reply to comment #15)
> > > > (In reply to comment #9)
> > > > > Contact attempted.
> > > > 
> > > > You contacted,attempted to contact, Box Net about this?
> > > 
> > > Yes.
> > > 
> > > > This problem is with their website page?
> > > 
> > > Yes.
> > > 
> > > > Why is that?
> > > 
> > > They are using non-standard things that have been removed.
> > > 
> > > > It worked before now with Fx 4 and it still works Fx 5 and Fx 6 so this code was removed in Fx 7 only then?
> > > 
> > > Yes.
> > > 
> > > > I wonder how many other 'defective sites' this code change will find when Fx 7 is the official release?
> > > 
> > > So far this is only the second site reported to have broken.  If we broke
> > > too much of the web we'll put the non-standard things back, but I don't
> > > think that's going to be the case here.
> > 
> > 
> > I see. May I ask what the other site is? I ask because I also have reported
> > that my banking site no longer works with Fx 7. 
> > 
> > https://bugzilla.mozilla.org/show_bug.cgi?id=666095
> 
> The other site is Gmail (Bug 662838).  Google is deploying a fix there.



Then I respectfully suggest that you give Chris Ilias, the Firefox Support help list moderator, a heads up on this. He is the poor guy that will be buried under *if* there are more than a total of only two sites on the whole web that do this.
Comment 20 David 2011-07-08 08:50:48 PDT
Uploading with the 2011-07-08 Aurora 7.0a2 and the 2011-07-08 Nightly 8.0a1 now succeeds.
Comment 21 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-07-08 08:52:02 PDT
(In reply to comment #20)
> Uploading with the 2011-07-08 Aurora 7.0a2 and the 2011-07-08 Nightly 8.0a1
> now succeeds.

Excellent.  Looks like they've fixed this on their end.  Marking fixed per comment 20.
Comment 22 Trif Andrei-Alin[:AlinT] 2011-08-22 02:00:30 PDT
Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110821 Firefox/9.0a1

I did not have any issues uploading files on latest nightly build and on 7.0b1.
Setting resolution to Verified Fixed.
If you feel otherwise, please feel free to change the status of the bug.
Thanks.
Comment 23 David 2011-08-22 02:17:40 PDT
(In reply to Trif Andrei-Alin from comment #22)
> Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0
> Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110821 Firefox/9.0a1
> 
> I did not have any issues uploading files on latest nightly build and on
> 7.0b1.
> Setting resolution to Verified Fixed.
> If you feel otherwise, please feel free to change the status of the bug.
> Thanks.

I am satisfied the this problem is resolved.

Note You need to log in before you can comment on or make changes to this bug.