The default bug view has changed. See this FAQ.

All uploads to Box Net fail

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: David, Assigned: khuey)

Tracking

({regression})

Details

(URL)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110616 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110616 Firefox/7.0a1

Attempting to upload a file fails and appears to freeze. The 'cancel upload' also fails and it requires a site log out to halt. This worked with 3.6.x, works with 4.0.1, 5.0x, and any 6.0x that I can find. And it used to work approximately one week or so previously with 7.0a1.

Reproducible: Always

Steps to Reproduce:
1.Load site in FF and login
2.Open a folder to receive the file and select a local file to upload 
3.

Actual Results:  
Upload appears to start but does not progress and never completes.

Expected Results:  
Upload should should complete and the site displays a 'file uploaded successfully screen.

This problem is found with both the x86 bit and the x86_64 FF 7.0a1. Uploads work with both the x86 and x86_64 Internet Explorer 9. 

This site offers a limited but free service (which could be used to test this) as well as a commercial and paid service.
(Reporter)

Updated

6 years ago
Version: unspecified → Trunk
(Reporter)

Updated

6 years ago
Summary: All uploads fail → All uploads to Box Net fail
Confirmed against Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110617 Firefox/7.0a1 ID:20110617030741

WFM against Mozilla/5.0 (Windows NT 5.1; rv:6.0a2) Gecko/20110617 Firefox/6.0a2 ID:20110617042008

Might help out finding a Range?
http://harthur.github.com/mozregression/
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

6 years ago
New things to me.

I ran the program as per your instructions as per your link and the links on it. It said that it sent a report.

I have a screen capture of the report number.

What now?
Nevermind, apparently it crashed and also me is having Problems running mozregression.

But you can do it by manually by checking the "mozilla-central" Directories (those containing the Win32 Builds) on http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/ for finding the last working and the first failing one.

Post the "Built from" URLs of both Builds you can get from "about:buildconfig".
(Reporter)

Comment 4

6 years ago
Hmm.. 

Non Geek alert Beep Beep.  :-)

Trying to help here. It says...

Last good nightly:  2011-06-05

First bad nightly:  2011-06-06


Else:

"build from" (fails) http://hg.mozilla.org/mozilla-central/rev/306bdc7101c3

"build from" (works)    whatever 2011-06-05   was? 

I don't have that build. I don't 'build' from code. I download and install and try 'your' builds.

How do I get that information for you?
Got it myself. Regression Range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4f9bbea16f75&tochange=caf81a228fff

+ Error Console Output:
Error: file_name is undefined
Source File: http://e1.boxcdn.net/resources/z7lqbr274h/js/section_application.js
Line: 1271
Component: General → General
Keywords: regressionwindow-wanted → regression
Product: Firefox → Core
QA Contact: general → general
What other scripts does that page load?

But in any case, looks like fallout from them relying on the old and nonstandard file api stuff Kyle removed....

Kyle, is this just an evangelism issue?  If so, can you contact them, please?
Blocks: 661876
Status: UNCONFIRMED → NEW
tracking-firefox7: --- → ?
Component: General → DOM
Ever confirmed: true
QA Contact: general → general
Seems plausible.  I'll dig in on Sunday.
Yes, this is tech evang.  They're using File.fileName and File.fileSize.
Assignee: nobody → khuey
Component: DOM → English US
Product: Core → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
Contact attempted.
(Reporter)

Comment 10

6 years ago
Was this "old and nonstandard file api stuff" also removed from FF 6.0 too? I ask because my bank site will no longer let me log in. I can login with the just released FF 5.0 but not with today's FF 6.0 Aurora nor with today's 7.0 Nightly.

My bank site is Suntrust and no I am not going to provide the password.  :-)  

https://www.suntrust.com/
No, it was not.  Please file a separate bug and CC me.

Comment 12

6 years ago
(In reply to comment #10)
> my bank site will no longer let me log in. I can login with
> the just released FF 5.0 but not with today's FF 6.0 Aurora nor with today's
> 7.0 Nightly.
> 
> My bank site is Suntrust and no I am not going to provide the password.

If it also fails while spoofing your UA string as Fx 5 (while using 6.0 or 7.0), then definitely file a new TE bug...and cc me as well :)
(Reporter)

Comment 13

6 years ago
(In reply to comment #12)
> (In reply to comment #10)
> > my bank site will no longer let me log in. I can login with
> > the just released FF 5.0 but not with today's FF 6.0 Aurora nor with today's
> > 7.0 Nightly.
> > 
> > My bank site is Suntrust and no I am not going to provide the password.
> 
> If it also fails while spoofing your UA string as Fx 5 (while using 6.0 or
> 7.0), then definitely file a new TE bug...and cc me as well :)

Sure. But how do I do that? Go easy now. Non Geek here.  :-)

Comment 14

6 years ago
The usual way is with something like this:

https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher/

cl
(Reporter)

Comment 15

6 years ago
(In reply to comment #9)
> Contact attempted.

You contacted,attempted to contact, Box Net about this? This problem is with their website page? Why is that? It worked before now with Fx 4 and it still works Fx 5 and Fx 6 so this code was removed in Fx 7 only then? I wonder how many other 'defective sites' this code change will find when Fx 7 is the official release?
(In reply to comment #15)
> (In reply to comment #9)
> > Contact attempted.
> 
> You contacted,attempted to contact, Box Net about this?

Yes.

> This problem is with their website page?

Yes.

> Why is that?

They are using non-standard things that have been removed.

> It worked before now with Fx 4 and it still works Fx 5 and Fx 6 so this code was removed in Fx 7 only then?

Yes.

> I wonder how many other 'defective sites' this code change will find when Fx 7 is the official release?

So far this is only the second site reported to have broken.  If we broke too much of the web we'll put the non-standard things back, but I don't think that's going to be the case here.
(Reporter)

Comment 17

6 years ago
(In reply to comment #16)
> (In reply to comment #15)
> > (In reply to comment #9)
> > > Contact attempted.
> > 
> > You contacted,attempted to contact, Box Net about this?
> 
> Yes.
> 
> > This problem is with their website page?
> 
> Yes.
> 
> > Why is that?
> 
> They are using non-standard things that have been removed.
> 
> > It worked before now with Fx 4 and it still works Fx 5 and Fx 6 so this code was removed in Fx 7 only then?
> 
> Yes.
> 
> > I wonder how many other 'defective sites' this code change will find when Fx 7 is the official release?
> 
> So far this is only the second site reported to have broken.  If we broke
> too much of the web we'll put the non-standard things back, but I don't
> think that's going to be the case here.


I see. May I ask what the other site is? I ask because I also have reported that my banking site no longer works with Fx 7. 

https://bugzilla.mozilla.org/show_bug.cgi?id=666095
(In reply to comment #17)
> (In reply to comment #16)
> > (In reply to comment #15)
> > > (In reply to comment #9)
> > > > Contact attempted.
> > > 
> > > You contacted,attempted to contact, Box Net about this?
> > 
> > Yes.
> > 
> > > This problem is with their website page?
> > 
> > Yes.
> > 
> > > Why is that?
> > 
> > They are using non-standard things that have been removed.
> > 
> > > It worked before now with Fx 4 and it still works Fx 5 and Fx 6 so this code was removed in Fx 7 only then?
> > 
> > Yes.
> > 
> > > I wonder how many other 'defective sites' this code change will find when Fx 7 is the official release?
> > 
> > So far this is only the second site reported to have broken.  If we broke
> > too much of the web we'll put the non-standard things back, but I don't
> > think that's going to be the case here.
> 
> 
> I see. May I ask what the other site is? I ask because I also have reported
> that my banking site no longer works with Fx 7. 
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=666095

The other site is Gmail (Bug 662838).  Google is deploying a fix there.
(Reporter)

Comment 19

6 years ago
(In reply to comment #18)
> (In reply to comment #17)
> > (In reply to comment #16)
> > > (In reply to comment #15)
> > > > (In reply to comment #9)
> > > > > Contact attempted.
> > > > 
> > > > You contacted,attempted to contact, Box Net about this?
> > > 
> > > Yes.
> > > 
> > > > This problem is with their website page?
> > > 
> > > Yes.
> > > 
> > > > Why is that?
> > > 
> > > They are using non-standard things that have been removed.
> > > 
> > > > It worked before now with Fx 4 and it still works Fx 5 and Fx 6 so this code was removed in Fx 7 only then?
> > > 
> > > Yes.
> > > 
> > > > I wonder how many other 'defective sites' this code change will find when Fx 7 is the official release?
> > > 
> > > So far this is only the second site reported to have broken.  If we broke
> > > too much of the web we'll put the non-standard things back, but I don't
> > > think that's going to be the case here.
> > 
> > 
> > I see. May I ask what the other site is? I ask because I also have reported
> > that my banking site no longer works with Fx 7. 
> > 
> > https://bugzilla.mozilla.org/show_bug.cgi?id=666095
> 
> The other site is Gmail (Bug 662838).  Google is deploying a fix there.



Then I respectfully suggest that you give Chris Ilias, the Firefox Support help list moderator, a heads up on this. He is the poor guy that will be buried under *if* there are more than a total of only two sites on the whole web that do this.

Updated

6 years ago
tracking-firefox7: ? → +
(Reporter)

Comment 20

6 years ago
Uploading with the 2011-07-08 Aurora 7.0a2 and the 2011-07-08 Nightly 8.0a1 now succeeds.
(In reply to comment #20)
> Uploading with the 2011-07-08 Aurora 7.0a2 and the 2011-07-08 Nightly 8.0a1
> now succeeds.

Excellent.  Looks like they've fixed this on their end.  Marking fixed per comment 20.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
status-firefox7: --- → fixed
Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110821 Firefox/9.0a1

I did not have any issues uploading files on latest nightly build and on 7.0b1.
Setting resolution to Verified Fixed.
If you feel otherwise, please feel free to change the status of the bug.
Thanks.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 23

6 years ago
(In reply to Trif Andrei-Alin from comment #22)
> Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0
> Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110821 Firefox/9.0a1
> 
> I did not have any issues uploading files on latest nightly build and on
> 7.0b1.
> Setting resolution to Verified Fixed.
> If you feel otherwise, please feel free to change the status of the bug.
> Thanks.

I am satisfied the this problem is resolved.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.