Closed Bug 664808 Opened 10 years ago Closed 10 years ago

Tests for HMAC failure conditions

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 664865

People

(Reporter: rnewman, Assigned: rnewman)

References

Details

(Whiteboard: [sync-hmac])

Attachments

(1 file)

No description provided.
Attached patch Test. v1Splinter Review
These two tests exercise 401 and 404 handling. They fail at this commit:

Author: Richard Newman <rnewman@mozilla.com>
Date:   Tue Apr 19 12:30:39 2011 -0700

    Bug 645918: attempt to fix random orange in test_bookmarks_engine. r=philiKON

immediately prior to the work for Bug 650208.

There is one commented-out check in this test:

    // TODO: this will change when we correctly handle 401s by aborting the
    // sync and starting again.
    //do_check_true(!hasData == !hasKeys);        // TODO

because after the 401 the server is left in an inconsistent, albeit recoverable, state.

I will file a bug (blocking this one) to address the inconsistency, and then uncomment this check and request review.
Attachment #539907 - Flags: feedback?(philipp)
Depends on: 664865
Duping this to the fix+test version.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 664865
Attachment #539907 - Flags: feedback?(philipp)
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.