Add xcpshell framework for Web sockets

RESOLVED DUPLICATE of bug 771884

Status

()

Core
Networking: WebSockets
--
enhancement
RESOLVED DUPLICATE of bug 771884
7 years ago
6 years ago

People

(Reporter: jduell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Now that we've split out the core network functionality of Websockets into necko (nsIWebSocketProtocol, soon-to-be-possibly-renamed nsIWebSocketChannel), we could conceivably test the network parts of the code with xpcshell instead of mochitest, if that makes life easier.

Marking as enhancement only, because mochitest is already working for WS and gives test coverage.   But this might make some things easier.

Main part to get this working would be JS code to spin up pywebsocket server.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 771884
You need to log in before you can comment on or make changes to this bug.