set default width of treecol

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
Themes
P2
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Joe Hewitt (gone), Assigned: Joe Hewitt (gone))

Tracking

Trunk
mozilla0.9

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
the summary says it all.  Prevents bouncing of aligmnent in columns on trees
that have flexing columns.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
(Assignee)

Comment 1

17 years ago
*** Bug 68162 has been marked as a duplicate of this bug. ***
nominating for 0.9

This affects a LOT of things badly.  Pull up a lot of RDF trees and scroll them,
and the columns will bound right and left as you go.  Sizing columns acts
weirdly (jumps to right edge), etc.  There are a number of older bugs filed on
these symptoms.

Things I know have problems:

Page Info
Bookmarks
History

probably others too
Keywords: mozilla0.9

Comment 3

17 years ago
hyatt says this is a one-liner, what's the line? :-)

Comment 4

17 years ago
Probably the addition of a width: #px; to 
http://lxr.mozilla.org/seamonkey/source/xpfe/global/resources/content/xul.css#30
0
(Assignee)

Comment 5

17 years ago
Created attachment 25486 [details] [diff] [review]
patch to fix
(Assignee)

Comment 6

17 years ago
reviews, anyone?
Keywords: mozilla0.9 → review
Priority: P3 → P2
Target Milestone: --- → mozilla0.9

Comment 7

17 years ago
What a good guess :-)

r=blake assuming that's the width we want.
(Assignee)

Comment 8

17 years ago
I used 16px because, that's the min-width, and it seems to me that most columns
in a tree should probably either flex, or have a size specified explicitly. 
This bug isn't about any treecols actually using the default width, it's about
working within the quirks of tree layout, which mis-calculates treecol width
when nothing is explicitly set.

Comment 9

17 years ago
sr=hyatt
(Assignee)

Comment 10

17 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
Marking verified on all platforms (2001-02-21-04-Mtrunk).
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.