It is possible to re-nominate a version for full review after it's been rejected

RESOLVED FIXED

Status

P3
major
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: kmag, Assigned: kmag)

Tracking

(Blocks: 1 bug)

Details

(Whiteboard: [ReviewTeam:P2])

(Assignee)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110513 Firefox/6.0a1
Build Identifier: 

I can't provide a review link at the moment, as the last two I came across were deleted by the time I got to writing the bug. It seems that it's possible for authors to re-nominate a version for full review after it's already been rejected. I'm not sure of the exact circumstances, but myself and several other editors have lately come across review pages where the current version has clearly been rejected. There is a rejection message in the review log and the file in question is admin-disabled and unreachable.

Hopefully someone can add a link to this bug the next time they come across such a review.

Reproducible: Always
(Assignee)

Updated

7 years ago
Whiteboard: [required amo-editors]
(Assignee)

Comment 1

7 years ago
This might fit the bill, although it was lited rather than rejected:

https://addons.mozilla.org/en-US/editors/review/briteclick?num=17

I suppose it's possible in this case that the file or version in question was deleted without notice, but in the other cases that seems unlikely given that the files are still inacessible.

Comment 2

7 years ago
dupe of bug 663868?
(Assignee)

Comment 3

7 years ago
(In reply to comment #2)
> dupe of bug 663868?

I'm not sure. There's a difference between a disabled add-on and a disabled version, and this also applies to versions which have been given prelim review but not disabled. But it may be the same issue that bug 663868 was referring to.
Summary: It is possible to re-nominate a version for full review after it's been rejected → It is possible to re-nominate a version for full review after it's already failed

Comment 4

7 years ago
When a add-on version is rejected review and if it has only one version, then the add-on status changes to "disabled by mozilla". I think that is the status she is referring to. I think both bugs are symptoms of the same problem. But I'll let whoever fixes this bug be the judge of that.
(Assignee)

Comment 5

7 years ago
That may be what the other reporter means, but when we (editors) talk about disabled add-ons, we generally mean admin disabled add-ons which authors can't upload new versions to at all. Rejecting all versions of an add-on does not put it into this state.
Duplicate of this bug: 663868
It is a dupe. However, I'm making this the main bug since there's more information here.
Severity: normal → minor
Priority: -- → P4
Target Milestone: --- → 6.1.3
Target Milestone: 6.1.3 → Q3 2011
(Assignee)

Comment 8

7 years ago
Here's an example of a full rejection that was re-nominated:

https://addons.mozilla.org/en-US/editors/review/log2stas?num=29
(Assignee)

Updated

7 years ago
Duplicate of this bug: 646864
(Assignee)

Comment 10

7 years ago
This is starting to become a major issue. We're having users nominate the same version three and four times before one of us gets fed up and has their add-on disabled.
Severity: minor → major
Priority: P4 → P3
Summary: It is possible to re-nominate a version for full review after it's already failed → It is possible to re-nominate a version for full review after it's been rejected
Target Milestone: Q3 2011 → Q1 2012
Reclassifying editor bugs and changing to a new whiteboard flag. Spam, spam, spam, spam...
Whiteboard: [required amo-editors] → [ReviewTeam:P2]
Resetting a bunch of missed milestones. Sorry for the bugspam.
Target Milestone: Q1 2012 → ---
(Assignee)

Comment 13

6 years ago
I feel like "This version has already been denied full review. Do not nominate it again or your listing will be disabled" is becoming my tagline.
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Assignee: nobody → kmaglione+bmo
(Assignee)

Updated

4 years ago
Blocks: 1004046
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.