If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<td background="______"> is not supported.

RESOLVED INVALID

Status

SeaMonkey
General
--
enhancement
RESOLVED INVALID
17 years ago
13 years ago

People

(Reporter: Malis Aiden, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; 0.7) Gecko/20010109
BuildID:    2001010901

If you look at: http://members.nbci.com/_XMCM/WIP666/index.html, there is a good
example of this "bug"... I say "bug" because I don't really call it a bug but a
good feature that should possibly be implemented and is used on many sites...
You seem to not be able to specify a background for <td> in tables. This is used
many times for auto-sizing menu borders etc.

Reproducible: Always
Steps to Reproduce:
simple.
<table width=400 height=400>
	<tr>
		<td width=400 height=400 background="blah.jpg">
	</tr>
</table>


Actual Results:  I ended up with a table of height and width 400 (not visible
obviously) with no background picture..

Expected Results:  It should have displayed a background "blah.jpg"

<table width=400 height=400>
<tr>
<td width=400 height=400 background="blah.jpg">
</tr>
</table>

That's about it :) Sorry if I put this in the wrong place or it's meant to not
be in or something along those lines =/
It is unlikely that this will be added, as "background" is not a standard HTML
attribute for TD.  The desired behavior can be obtained by applying the CSS
style rule "background-image: url("blah.gif")" to the table cell in question. 
Should probably be INVALID.

Comment 2

17 years ago
should be made through css..
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.