"ASSERTION: We shouldn't have another size than small and regular for the moment"

RESOLVED FIXED in mozilla8

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Assigned: mounir)

Tracking

(Blocks: 2 bugs, {assertion, regression, testcase})

Trunk
mozilla8
All
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 539992 [details]
testcase

###!!! ASSERTION: We shouldn't have another size than small and regular for the moment: 'size == NSSmallControlSize', file widget/src/cocoa/nsNativeThemeCocoa.mm, line 201

The assertion was added in bug 634551.
(Assignee)

Updated

6 years ago
Depends on: 665571
(Assignee)

Comment 1

6 years ago
Created attachment 540498 [details] [diff] [review]
Patch v1

The assert is correct and this patch should fix.
Though, a better fix should come with bug 665571.
Assignee: nobody → mounir.lamouri
Status: NEW → ASSIGNED
Attachment #540498 - Flags: review?(mstange)
(Assignee)

Updated

6 years ago
Whiteboard: [needs review]
(Assignee)

Updated

6 years ago
Hardware: x86_64 → All
Attachment #540498 - Flags: review?(mstange) → review+
(Assignee)

Updated

6 years ago
Flags: in-testsuite+
Whiteboard: [needs review] → [inbound]
(Assignee)

Updated

6 years ago
Attachment #540498 - Flags: checkin+
I backed it out because of reftest oranges on OS X:

http://hg.mozilla.org/integration/mozilla-inbound/rev/ea1856ff64d1
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308595010.1308596968.20417.gz
Whiteboard: [inbound]
(Assignee)

Updated

6 years ago
Attachment #540498 - Flags: checkin+ → checkin-
(Assignee)

Comment 3

6 years ago
(In reply to comment #2)
> I backed it out because of reftest oranges on OS X:
> 
> http://hg.mozilla.org/integration/mozilla-inbound/rev/ea1856ff64d1
> http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308595010.
> 1308596968.20417.gz

Interesting. It fails on the test I wrote and was passing locally... Yay \o/
(Assignee)

Updated

6 years ago
Whiteboard: [in
(Assignee)

Comment 4

6 years ago
The assertion should have been fixed by bug 665571. Test pushed to m-i.
Whiteboard: [in → [inbound]
(Assignee)

Comment 5

6 years ago
Pushed:
http://hg.mozilla.org/mozilla-central/rev/ec99f33d4f76
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla8
You need to log in before you can comment on or make changes to this bug.