Seamonkey doesn't display POP3 mail server warning messages

VERIFIED FIXED in M11

Status

MailNews Core
Networking
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: pmock, Assigned: Scott MacGregor)

Tracking

Trunk
All
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PR1])

(Reporter)

Description

19 years ago
Build:
  Win32 May 17 (1999051708) Seamonkey build installed on Gateway P200, Win98
  Linux May 17 (1999051708) Seamonkey build installed on Compaq P200, Redhat 5.2
  PPC May 17 (1999051709) Seamonkey build installed on PPC 8500/180, Mac OS 8.51

Problem:
  Seamonkey is not displaying warning messages from the mail server,
specifically the error messages that the mail account is locked by another mail
session.  This situation occurs on Netscape 3.x Mail servers when someone is
trying to Get Msg on the same test account using POP and IMAP.

The error message that is displayed in Communicator 4.51 reads,
 "Could not log into the mail server.
  The mail server responded:
  Your mail account is locked by another mail session
  ...please wait a few (up to 10) minutes and try again.
  Please enter a new password for user
  ..."

This issue is confusing to the user since Seamonkey doesn't give you any
feedback and it leaves the user to guess why their Get msg operation failed. We
ran into this problem when people tried using the same test account without
knowing it.

Note: I was able to reproduce our test server "zia" running 3.x Netscape mail
server but have not been able to reproduce on Nsmail-2 running a 4.x mail server

Steps to reproduce problem:
0) Mail server info
    Incoming server: zia.mcom.com
    Outgoing server: zia.mcom.com
    test account: test02
    password: netscape
    email: test02@zia.mcom.com
1) Configure your seamonkey prefs50.js for this mail account for POP3
2) On another machine, configure Commmunicator/Seamonkey for the same mail
account except for IMAP
3) On the IMAP client, retrieve mail
4) On the POP client, try to retrieve mail by clicking on the Get Msg button
   Nothing happens, no error message

5) Exit the IMAP client
6) On the POP client, try to retrieve mail again
   Now mail messages are retrieved.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M9
(Assignee)

Comment 1

19 years ago
we don't have dialogs hooked up to mozilla anywhere in the product including
mail protocols. we also don't have status, progress, prompt for password etc.
these aren't scheduled as features until m9 or m10 so I wouldn't look for seeing
these types of dialogs until then. I'll mark it m9 for now...

Comment 2

19 years ago
Moving all Mail/News Networking bugs to Mail/News Networking-Mail

This may re-open previously Verified bugs due to a Bugzilla bug...if so, I will
fix those bugs.
(Assignee)

Updated

19 years ago
Target Milestone: M9 → M10
(Assignee)

Comment 3

19 years ago
we still don't have alert dialogs working yet. In any case this is post necko
landing work so not in m9....

Updated

19 years ago
Whiteboard: [PR1]

Comment 4

19 years ago
I think we need warnings displayed in PR1, assuming that dialogs work, so I put
this designation in the Status Whiteboard for this bug

Comment 5

19 years ago
I can take this for imap, anyway. Perhaps we should open a new bug for imap and
leave this one for POP3. I'll do that and xref this bug.

Comment 6

19 years ago
see 11970 for imap bug. Probably need a bug for NNTP as well.

Comment 7

19 years ago
I entered http://bugzilla.mozilla.org/show_bug.cgi?id=11977 for NNTP.

Comment 8

19 years ago
Bulk move mail/news M10 bugs to M11

Updated

19 years ago
Summary: Seamonkey doesn't display mail server warning messages → Seamonkey doesn't display POP3 mail server warning messages

Comment 9

19 years ago
changing summary since IMAP is done.
(Assignee)

Comment 10

19 years ago
*** Bug 13777 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Blocks: 11091

Comment 11

19 years ago
(target milestone is M11 or M12 - add to mail beta tracking bug)
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

19 years ago
I added all the old 4.5 status and alert messages for pop tonight. Marking this
bug as fixed.

Updated

18 years ago
QA Contact: lchiang → huang

Comment 13

18 years ago
Take this bug for verifying since bug#11970 for IMAP and bug#11977 for NNTP all
refer to this bug. Change QA Contact to me (Cc:Lisa) even it regarding to POP!!

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 14

18 years ago
Verified on 11-09-11-M11 build on WinNT & Linux platforms:

One IMAP & one POP Clients accessed in the same account(test01)
from the same server (netscape Messaging Server 3.x : zia.mcom.com)

Verified that the error message is displayed in 5.0 now...
Passed by retesting. Mark bug as Verified!!

Comment 15

18 years ago
11-23-09-M12 build/clients info: WinNT <-> Win98
Scott, I know this bug have been fixed for the 3.01 server (zia.mcom.com)
I am just wondering know whether this warning messages should display for the
4.03 server(nsmail-1)& 4.1 server(nsmail-1/nsmail-2)? it seemed this warning
message only displayed on the 3.01 server. I verified on the 4.03 & 4.1 servers
-> the warning not displayed....
If this dialog should displayed for all the versions' servers.
I think that I am going to reopen this bug......
Can you tell me the answers? Thanks.

Comment 16

18 years ago
Sorry! The 4.1 server should be nsmail-5(tintin) or nsmail-2(dredd).

Comment 17

18 years ago
Verified on Communicator 4.7 for 4.03/nsmail-1 & 4.1/nsmail-2|nsmail-5 server.
Also confirmed with Peter -  This warning message only displays on the 3.01
Messaging Server/zia.mcom.com. The 4.x server won't display this warning
message. Leave this bug as Verified!
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.