When mouseovering an image-swap JS, moz removes first image, then waits for second image to load, leaving whitespace

RESOLVED DUPLICATE of bug 66064

Status

()

Core
Layout
--
minor
RESOLVED DUPLICATE of bug 66064
18 years ago
18 years ago

People

(Reporter: Mark Slater, Assigned: clayton)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20010124
BuildID:    2001012420

When mouseovering an image that has JS image-swap code on it, moz immediately
removes the first image and waits til the second image is loaded.

Reproducible: Always
Steps to Reproduce:
Goto any site without preloaded images
Mouseover images
Watch in awe as Moz displays whitespace until new image is loaded

Actual Results:  Moz shows whitespace

Expected Results:  Moz should wait til new image is loaded, until then, it
should still display old image

This is somewhat a logical question (eg., the browser thinks "The user has
mouseovere'd, therefor i HAVE to do *something*"), I suggest it should wait till
the new image has loaded, and until displays the old image, with the throbber...
uh... "throbbin", to signify that something else *IS* loading.
Assignee: rogerl → clayton
Component: Javascript Engine → Layout
QA Contact: pschwartau → petersen
This is not a javascript engine issue, certainly.  Tentatively reassigning to
layout.

Comment 2

18 years ago

*** This bug has been marked as a duplicate of 66064 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.