Crash trying to open message attachment [@ nsHtml5TreeBuilder::flushCharacters() ]

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: stanio, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20110608 SeaMonkey/2.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20110608 SeaMonkey/2.1

Opening a message attachment to another message causes crash.


Reproducible: Always

Steps to Reproduce:
1. Attach a simple message (no attachments) to a new message;
2. Save as draft or send to self;
3. Open the attached message from the preview of the new message.


Actual Results:  
SeaMonkey crashes.


Expected Results:  
SeaMonkey should not crash.

Comment 2

8 years ago
Go to about:crashes. Select/click on the most recent link and let us know where it leads to on crash-stats.mozilla.
(Reporter)

Updated

8 years ago
Attachment #540260 - Attachment mime type: application/octet-stream → message/rfc822
(Reporter)

Updated

8 years ago
Version: unspecified → SeaMonkey 2.1 Branch

Comment 4

8 years ago
Possibly a duplicate of Bug 569328
Crash Signature: [@ nsHtml5TreeBuilder::flushCharacters() ]
Keywords: crash
Summary: Crash trying to open message attachment → Crash trying to open message attachment [@ nsHtml5TreeBuilder::flushCharacters() ]

Comment 5

8 years ago
Given where it crashes, this looks like it's in the HTML5 parser and should be moved there.
Component: MailNews: General → HTML: Parser
Product: SeaMonkey → Core
QA Contact: mail → parser
Version: SeaMonkey 2.1 Branch → unspecified
(Reporter)

Comment 7

8 years ago
Looks really similar to Bug 647926 (may be a duplicate).
(Reporter)

Comment 8

8 years ago
Note, after Bug 665313 got fixed I'm not able to reproduce the crash using SM 2.4a1 nightlies, for example, because the message attachments are now opened as expected.
(Reporter)

Comment 9

8 years ago
Should I resolve this as WORKSFORME, given I cannot reproduce the issue with latest versions using the original steps to reproduce?  One could still reproduce it using SM 2.1, if that's relevant.

Updated

8 years ago
Duplicate of this bug: 669894

Updated

8 years ago
Severity: normal → critical
OS: Windows NT → Windows 7
(In reply to Stanimir Stamenkov from comment #8)
> Note, after Bug 665313 got fixed I'm not able to reproduce the crash using
> SM 2.4a1 nightlies, for example, because the message attachments are now
> opened as expected.

(In reply to Stanimir Stamenkov from comment #9)
> Should I resolve this as WORKSFORME, given I cannot reproduce the issue with
> latest versions using the original steps to reproduce?  One could still
> reproduce it using SM 2.1, if that's relevant.

yup. WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.