svg images are not scaled when zoom is increased with STRG++

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: maximilian.mehnert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 4 obsolete attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686 on x86_64; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:5.0) Gecko/20100101 Firefox/5.0

When a page containing an SVG image (<img src=...) is zoomed, the SVG image remains the same size.

Reproducible: Always
http://blog.echo-flow.com/2010/10/16/masters-thesis-update-1/ zooms fine for me on both Firefox 4 and Firefox trunk. Do you have an example that does not?
(Reporter)

Comment 2

8 years ago
Created attachment 540301 [details]
example to reproduce reported effect
Can you attach individual files please?
(Reporter)

Comment 4

8 years ago
Created attachment 540305 [details]
example to reproduce reported effect
Attachment #540301 - Attachment is obsolete: true
(Reporter)

Comment 5

8 years ago
Created attachment 540306 [details]
example to reproduce reported effect svg file
(Reporter)

Comment 6

8 years ago
Created attachment 540307 [details]
example to reproduce reported effect css file
Attachment #540305 - Attachment mime type: text/plain → application/xhtml+xml
Attachment #540305 - Attachment mime type: application/xhtml+xml → text/html
Comment on attachment 540307 [details]
example to reproduce reported effect css file

>
>body {
>	margin:0;
>	padding:0;
>	border:0;			/* This removes the border around the viewport in old versions of IE */
>	width:100%;
>	background:#fff;
>	min-width:600px;		/* Minimum width of layout - remove line if not required */
>					/* The min-width property does not work in old versions of Internet Explorer */
>	font-size:11pt;
>
>        font-family: "Liberation Sans";
>        font-style: normal;
>}
>a {
>	color:#13235b;
>}
>img {
>	margin:10px 0 5px;
>}
>
>#header {
>	clear:both;
>	width:100%;
>        font-size: 90%;
>        text-align: center;
>}
>
>#logo {
>        background: url(test.svg);
>        width: 247.3px;
>        height: 90.6px;
>	margin: 15px auto;
>        text-align: center;
>	}
>
Attachment #540307 - Attachment mime type: text/plain → text/css
Created attachment 540317 [details]
example to reproduce reported effect
Attachment #540305 - Attachment is obsolete: true
Created attachment 540318 [details]
example to reproduce reported effect css file
Attachment #540307 - Attachment is obsolete: true
Created attachment 540319 [details]
example to reproduce reported effect
Attachment #540317 - Attachment is obsolete: true
The example works for me now that I've fixed up the links.

Is browser.zoom.full set to true in your about:config?
(Reporter)

Comment 12

8 years ago
Huuh. browser.zoom.full was set to false. That was it. Don't know why it had a non-default value. Sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.