AMO View Stats page is showing wrong "addons for..." application

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: Ken, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: 

AMO has started to show the wrong application on the "addons for..." header.  For instance, I'm seeing "Addons for SeaMonkey" listed on https://addons.mozilla.org/en-US/statistics/addon/3699 even though that addon is only for Firefox.

Reproducible: Always


Actual Results:  
Shows "Addons for SeaMonkey"

Expected Results:  
Should show "Addons for Firefox"

Comment 1

7 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.20pre) Gecko/20110606 Lightning/1.0b2pre SeaMonkey/2.0.15pre

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110619 SeaMonkey/2.4a1

I see "Addons for Firefox" in both versions of SeaMonkey.
(Reporter)

Comment 2

7 years ago
I've discovered that "SeaMonkey" in "Addons for..." was getting set by a cookie.  This is a really confusing UI issue.  The "Addons for..." header should be limited by what applications the displayed addon is valid for.  If an addon is valid for say both Firefox and SeaMonkey, then it would be okay to use the header "Addons for SeaMonkey".  HOWEVER, if an addon is only valid for say Firefox then the header should say "Addons for Firefox" regardless of what the cookie says.

Comment 3

7 years ago
Created attachment 570192 [details]
screenshot

Statistics pages now has new design.
Header do not show "Addons for..." anymore

Window shows correct titles as per selected application

pls see attached screenshot

Comment 4

7 years ago
closing this bug, as this is no more valid with new design
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 5

7 years ago
Updating bug status to Resolved/Fixed
since this is fixed with new design
Resolution: INVALID → FIXED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.