If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

CSS animations do not work for the <progress> element's anonymous bar element

RESOLVED DUPLICATE of bug 662351

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 662351
6 years ago
6 years ago

People

(Reporter: Kai Liu, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
CSS animations can be applied to the <progress> element itself, but not to the anonymous child element that represents the internal colored bar.

CSS animations are necessary for the internal bar element because animations are used to show that <progress> is in an indeterminate state.  All of the different indeterminate animations currently used by <progress> are generated by the native theme code: there is no CSS-only fallback.  This means that there is no indeterminate animation when there is no native theme support (Windows Classic or other platforms for which a native rendering was not implemented) or when the presence of author styling disables the native appearance.  Coupled with the lack of CSS animation support for the internal bar element, this means that indeterminate animations are currently impossible for these cases.
(Reporter)

Updated

6 years ago
Blocks: 665367
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 662351
No longer blocks: 665367
You need to log in before you can comment on or make changes to this bug.