{compat} <P> tags in links break links

VERIFIED FIXED in M7

Status

()

Core
HTML: Parser
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: cpratt, Assigned: harishd)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ascertaining blame; waiting for response, URL)

(Reporter)

Description

19 years ago
build id: 1999051708
platform: windows NT

here's the sample HTML:

<HTML><HEAD><TITLE>Ich biete an</TITLE></HEAD>
<BODY><A HREF="biete.htm" TARGET="main"><P>Ich<BR>biete an</P></A></BODY>
</HTML>

if you remove the <P> tags, the link works. as it's written above, however, the
link does not work.

of course, this is bad html (<P> is a block-level tag - and only %inline tags
are allowed inside of an anchor). i'm filing this bug only for backwards
compatibility reasons - if we don't fix this, this is fine too, I'm sure.

Updated

19 years ago
Assignee: karnaze → kipp

Comment 1

19 years ago
Reassigning to Kipp.
Whiteboard: ascertaining blame; waiting for response
This may be a parser issue. When using CNavDTD, are we putting the <P> inside
the link or are we closing the link before the <P>?
(QA don't get debug builds so I cannot just dump the document tree...)
[ccing rickg]

rickg, could you look at the comment dated 05/19/99? Thanks.
Assignee: kipp → rickg
Severity: minor → normal
Component: HTMLFrames → Parser
Summary: <P> tags in links break links → {compat} <P> tags in links break links
Rick, I'm assigning this bug to the parser for you to see if it is a parser
issue or a layout issue. If it is a layout issue, please assign back to kipp in
the layout component. Thanks.
(Assignee)

Updated

19 years ago
Assignee: rickg → harishd
(Assignee)

Comment 5

19 years ago
This seem to be a parser bug.

Assigning to myself.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M7
(Assignee)

Comment 6

19 years ago
*** Bug 7377 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
For compatibility sake allowing anchor to contain %block.

Marking the bug fixed.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

19 years ago
Fixed. 1999061409 build, NT. Long live bad HTML.
You need to log in before you can comment on or make changes to this bug.